Roomba Series 700/800 will not turn on

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » January 10th, 2017, 11:03 am

No time right now. I feel like this guy.
https://m.youtube.com/watch?v=SdaA1PFyuR8
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 9th, 2017, 2:45 pm

870 is in the shop with no response from buttons. Set on Base and goes into refresh charge with CE3 after 9 seconds. Term software reads mV 111, mA 0, tenths-deg-C 23.1, mA 0, state 3
charging-error 3
5V reg available @ L1.
6.4V supply to U4 pin 4 available while on base.
U4 supplys the reference for battery voltage, current and temperature to the MCU.
Simular to R3 U8 but not exact.
Time to trace U4.
First rule of troubleshooting, fix known problems first.
No charging current on base, looking for increase in bat V, check U4 battery reference first, U4 A2 pins 5,6 & 7.
20170209 16:00
WELL, pin 5 is tied to system return.
It appears 700/800 process the VBAT sense differently than R3. Thermistor sense A3 and Current Sense A4, A1 are processed thru U4.
20170209 16:40
Shot in the dark, looked @ R3 U8 sketch, found R207, 475K. Visual trace leads to VBAT, no continuity.
Last edited by a1robotrepair on February 10th, 2017, 6:19 pm, edited 1 time in total.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 9th, 2017, 7:17 pm

https://m.youtube.com/watch?v=g0qTOLBhlVs
Installed jumper, happy start battery 5 note song :dance:
No clean or other button response. :violin:
Placed on base, CE3 after 9sec.
mV 15502, that part is fixed, mA 0 tenths-deg-C 252 mAH 2696 state 5
More investigating needed.
The thru board copper is blown from VBAT to R207. Expect something similar, maybe in same area.
IMG_1516.JPG
Last edited by a1robotrepair on February 25th, 2017, 1:53 pm, edited 1 time in total.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 10th, 2017, 3:34 pm

Didn't find obvious blown trace.
Traced UI board SW1, Clean button.
UI J1-3 to R9 (103;10K) SW1+
SW1- to J1-4
To main board.
J13-3 to D47-C visual trace, no conductivity. Another Jumper. Same area blown trace.
Turns on with buttons :dance:
Charging error 3. :violin: expected. Q17 not turning on. Another blown trace?
IMG_1517.JPG
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 11th, 2017, 9:08 pm

a couple of drawings to help with troubleshooting
700800-Charging (2).png

U4 (2).png

700-Reg-V (3).png
Last edited by a1robotrepair on February 23rd, 2017, 7:37 pm, edited 6 times in total.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 11th, 2017, 11:43 pm

Q17 is working fine.

factory-test 12 battery-sensors
(battery-voltage-ok?) mV 552 min 431 max 647 PASS
(battery-temperature-ok?) PASS
(baseline-current-ok?) mA -111 min -200 max -80 mV 15363 degrees-C 24 PASS

Q18 is not.

factory-test 25 charger-watchdog
not (ext-charger-available?) PASS
wait-true-for-time (32 ticks): (test-charger-available?)
(int-charging-watchdog-current-ok?) mA 0 min -31 max 31 mV 15585 degrees-C 25 PASS


factory-test 26 ext-charger-recovery
wait-true-for-time (32 ticks): (ext-charger-available?)
(ext-charging-recovery-current-ok?) mA 1143 min 250 max 350 mV 15808 degrees-C 25 FAIL


factory-test 27 ext-charger-on
wait-true-for-time (32 ticks): (ext-charger-available?)
(ext-charging-current-ok?) mA 1162 min 1000 max 1400 mV 15864 degrees-C 25 PASS


factory-test 28 ext-charger-trickle
wait-true-for-time (32 ticks): (ext-charger-available?)
(ext-charging-trickle-current-ok?) mA 1154 min 40 max 70 mV 15947 degrees-C 25 FAIL

Q18 full on during recovery and trickle.
Need to check R277, R276, C224, D4, Q21, Q21e to MC.
http://www.mouser.com/ds/2/389/str730fz2-956790.pdf
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby przemo33 » February 14th, 2017, 10:19 am

Hello,
In my case ,on PCA at the connection of L1 and C287 is 1,6V (instead 5V) :(

Regards.
przemo33
Robot Groupie
 
Posts: 69
Joined: March 11th, 2015, 2:46 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 14th, 2017, 1:35 pm

Updated charging DWG with corrections. The Clean Button along with the robot being placed on the charger gives a signal to the Voltage Converter U3 on pin 3. Will be investigating SMPS soon. 700 without button responses. Can turn on with term software and buttons work and bot acts normal, starts cleans docks schedules,...normally.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 17th, 2017, 1:54 pm

700/800 5V Reg
DWG added earlier to this Post page.
LM3489x Hysteretic PFET Buck Controller With Enable Pin
http://www.ti.com/lit/ds/symlink/lm3489.pdf
przemo33, First thing I would check from here is Q15 collector for 3.3V. The top DWG.
Remove Battery and continuity check pin 2 and 6 to SysRtn pin 8 to
d47.
Last edited by a1robotrepair on February 25th, 2017, 2:07 pm, edited 1 time in total.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby przemo33 » February 21st, 2017, 3:04 am

Hello,
Voltage between Q15c and VBAT (+) is 12.8V

On U3:
Continuity between Pin 2 and Pin 6 to SYS_RTN - OK

Continuity between Pin 8 and D47 - OK

Regards
przemo33
Robot Groupie
 
Posts: 69
Joined: March 11th, 2015, 2:46 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 22nd, 2017, 12:11 am

przemo33 wrote:Hello,
Voltage between Q15c and VBAT (+) is 12.8V

All V readings to SysRtn.
I was looking for 3.5V to sysrtn for a fully charged battery. -12.8 to VBAT is reasonable for a fully charged battery.
The junction of R174 & R175 that feeds the feedback pin, FB, pin4 U3, should read 1.24V.
I get a 13.7V reading on the Gate, pin3 of Q7. Robot off, battery 16V.
Lastly, I sense pin 1 should be 5.1V and R78 to pin 5 U3 should be 140mV less than D47 to sysrtn.
Check D2.
Last edited by a1robotrepair on February 22nd, 2017, 1:40 am, edited 2 times in total.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 22nd, 2017, 12:46 am

My inop 870 is now charging. While testing I must have Jared whatever was causing a short circuit to correct itself.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Re: Roomba Series 700/800 will not turn on

Postby przemo33 » February 23rd, 2017, 3:17 am

Hello,
a1robotrepair :cheers:
Thank you very much, one "alive" :)
There was no continuity between pin 1 U3 and Q7d

Roomba runs OK !!!

Only one problem is - No sound is silence in speaker (the speaker is good)

Regards
przemo33
Robot Groupie
 
Posts: 69
Joined: March 11th, 2015, 2:46 am

Re: Roomba Series 700/800 will not turn on

Postby a1robotrepair » February 24th, 2017, 10:12 am

Cool beans.
With your and my posts, one can surmise what the V readings on the Buck Controller are during Current limit conditions.

The blown traces on my 800 main board both occurred next to the VBAT on the bottom of the board, indicating that that area got very hot.

I suspect a problem @ Q19 was causing my CE3. I cleaned and traced it before reconnecting to the base. It charged normally afterward.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 782
Joined: October 14th, 2013, 8:40 am

Previous

Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: vtvrobot and 175 guests