New Roomba 880 making squeaking sound

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

New Roomba 880 making squeaking sound

Postby Robowick » September 18th, 2014, 7:56 am

My new Roomba 880 is starting to make a squeaky sound.
Only happens sometimes, especially when going over carpets or rugs - but is starting to annoy.
Is this normal?
I've uploaded my recording here: http://youtu.be/tj902jqRKws

thanks.
Robowick
 
Posts: 5
Joined: September 15th, 2014, 9:14 am

Re: New Roomba 880 making squeaking sound

Postby vic7767 » September 18th, 2014, 9:13 am

Remove the brushes then run your Roomba. Is the noise still occurring?
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14330
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: New Roomba 880 making squeaking sound

Postby Robowick » September 19th, 2014, 6:39 am

Thanks vic. I tried removing the brushes, and it's still making the squeaky sound. I've contacted Roomba support and they suggested cleaning the castor wheel, which I tried but didn't improve.
Robowick
 
Posts: 5
Joined: September 15th, 2014, 9:14 am

Re: New Roomba 880 making squeaking sound

Postby vic7767 » September 19th, 2014, 10:01 am

There was a major redesign of the front swivel wheel. You might consider using a drop of very lightweight oil on all moving parts of the swivel wheel. Also to help discover where the noise is actually coming from you could just remove the CHM (Brush Deck) completely and then run a short cleaning session just to see if the noise is coming from the brush deck assembly. It the noise continues then try removing the side brush module. If it still continues that would narrow it down to one of the two drive wheels.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14330
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: New Roomba 880 making squeaking sound

Postby Conker » September 24th, 2014, 5:33 pm

It's the castor. The only way to get it to stop squeaking is to strip it down and clean it THOROUGHLY on a very regular basis.
Conker
 
Posts: 8
Joined: April 1st, 2014, 10:14 am

Re: New Roomba 880 making squeaking sound

Postby susi_sorglos » September 24th, 2014, 7:31 pm

@Robowick: I experienced the same squeaking noise as in your recording.

I could elliminate this annoying squeaking as follows:

As I've figured out with my roomba 880 the reason for such squeaking noise are the axis of electric motors (standard motor rp 360 st) of the right and left wheels and the dust bin motor too. I opened both wheels and tried at first using dry lubricant onto the electric motor axis, no success. After that I tried to use a silicon lubricant, but no success too. At the end I followed the hint, I've found in this forum, using WD-40. Great! Now the roomba 880 makes the standard cleaning noise, but that annoying squeak is gone away.

I'm dissatisfied with that such cheap components are build in such expensive product like roomba 880.

BTW: Because of the high modularity of roomba 880 I was able to dis-/assemble the wheels and the dust bin nondestructive.
susi_sorglos
 
Posts: 2
Joined: September 24th, 2014, 6:49 pm

Re: New Roomba 880 making squeaking sound

Postby Robowick » September 25th, 2014, 1:31 am

Thanks everyone for your suggestions.

iRobot support said that the caster needs replacement and have sent one out to me. Although I'm not convinced it was the caster making the squeak, I will try the replacement part first - if it still doesn't work, I'll try some WD-40.
Robowick
 
Posts: 5
Joined: September 15th, 2014, 9:14 am

Re: New Roomba 880 making squeaking sound

Postby Nataliegriepp » July 17th, 2017, 10:26 am

I have determined the squeaking came from the (yellow) side brush (that dusts particles into the path of the roomba). I removed with a screwdriver, sprayed with a small bit of wd40. I also applied it around the outside of the yellow part and spun it around so as to spread the oil. I gave it some time to run to see if the problem would reoccur. This fixed the issue.
Attachments
image.jpg
Nataliegriepp
 
Posts: 1
Joined: July 17th, 2017, 10:03 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: aarolar, chefkeith, TechGuy, Tenergy, vic7767 and 374 guests