560 doing the 9 beep circle dance - BUT....

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 8:56 am

So we have an old 560 that conked out with the 9 beeps circle death dance ages ago. iRobot told us it's junk. Well, I just found the thing during a move and decided to try to figure it out. I ordered a new battery since it's been sitting for years. Put it in and it worked pretty good. For like 15 minutes. Then it started doing the dance and then the "uh Oh" and then the 9 beeps. I performed the internal bumper test and it seems to pass. Left side will illuminate the spot button when depressed, and turn off when I let go. Same with the right side.

It seems like if I leave the 560 alone for a while after it does the 9 beep error, it will work again, but only for a little while. Maybe 5 minutes. Or maybe 15. Or maybe even only 2 minutes. I think the longer I leave it sit the longer it will operate before I get the 9 beep death dance. So, I'm totally able and willing to try and fix this thing.... it didn't get used much at all in all the years we owned it. I'd just like to zero in on this error and make sure I'm changing out the proper components. So, to all that answer me I GREATLY APPRECIATE your guidance and suggestions.
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 9:42 am

UPDATE- Now I'm seeing that my left bump sensor is saying it's faulty. IT's stays green after I left go of it during the diagnostic test. So, looks like I should change out the sensors. Can anyone recommend the best place to buy them?? Thanks!
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby vic7767 » May 14th, 2018, 9:57 am

Look for a "cliff sensor harness" on ebay or possibly Amazon.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14627
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 2:03 pm

Another Update-
So I cracked the Roomba open to first check on the sensor. It wasn't dirty. The small IR sensor board looked like maybe it was a tad askew within the bumper sensor housing, but only very slightly. I pushed it back into it's proper position hoping just maybe that was the culprit. I put the whole thing back together and it ran for a real long time. Like the longest ever. Then eventually I got the 9 beep error again and it the Diagnostic test said the left sensor is again faulty. Of course, if I shut it off and wait it will work again.

So, my question now is can the IR bump sensors work intermittantly? Can they become temperamental and work, then not, then work, and then not???
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby vic7767 » May 14th, 2018, 2:25 pm

Anytime the Roomba is turned off, or battery removed, or cleaning session terminated, the error buffer register bit that stores error indications (like a bump sense) are all reset so when your Roomba starts a new cleaning run, until a bump sensor is triggered everything seems fine...... And then bump and error.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14627
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 2:45 pm

Thanks. So you’re saying Even though it’s seemingly working longer those bumps sensor issues are still there. And the bumo sensor is indeed faulty and Should be replaced?
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 2:47 pm

why does it sometimes pass the internal diagnostic testing of the left bump sensor, and then sometimes fail?
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby vic7767 » May 14th, 2018, 3:21 pm

So you are seeing no LEDs on when you enter test two but after you push the left or right bumper an LED turns on and won't go off? If so the sensor is defective.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14627
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 560 doing the 9 beep circle dance - BUT....

Postby leonicholson » May 14th, 2018, 3:43 pm

There are some good utube videos on replacing these.
That is an advantage with the 500/600's. Available parts and lots of repair videos. :)
leonicholson
Robot Groupie
 
Posts: 70
Joined: November 3rd, 2017, 5:25 pm

Re: 560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 4:48 pm

I’m saying tsometimes when I do the test it passes the bumper test. I’ll press either side and the light will go on when I press it, and then goes off when I let go. But then there are other times when I’ll do the test and when I press that left side bumper the light will stay on. Indicating a failed sensor. So I’m just kind of wondering if the sensors can work, and then not work, and then work and repeat that cycle. Or do these sensors crap out and then they’re done and you get a permanent failure
Last edited by scr2000 on May 14th, 2018, 5:01 pm, edited 1 time in total.
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby vic7767 » May 14th, 2018, 7:17 pm

The 500 series of Roomba was famous for having this IRED fault. The thought was that there was an inferior run by a manufacturer that supplied iRobot with these sensors. Most of the time the failure is a hard fault but of course there will also be intermittent failures as well. It is good that you isolated the fault to just one side. Folks that decide to repair this fault either order the individual Emitter - receiver pair and replace both the left and right bumper sensors. Those that don't have the tools purchase a complete wiring harness with the two bump sensors as well as the front set of cliff sensors since they are all within the same wiring harness / connector.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14627
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 560 doing the 9 beep circle dance - BUT....

Postby scr2000 » May 14th, 2018, 8:30 pm

I’m seeing a full harnesses with both bumper sensors and Cliff sensors for around $20 shipped. This is an eBay listing. It’s a used part, but they say the sensors have been replaced with new ones. This seems like a pretty good deal considering single IR board sensors on a retail robot site are $20. Those would require more work too! What are your thoughts?
scr2000
 
Posts: 7
Joined: May 14th, 2018, 8:47 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby vic7767 » May 14th, 2018, 8:49 pm

That's a damn good price for an upgraded bumper sensor pair along with the cliff sensor array. I offer repair services for that error but at a much higher price.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14627
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 560 doing the 9 beep circle dance - BUT....

Postby a1robotrepair » May 16th, 2018, 4:15 pm

When you have 25 sets of these sitting in a full drawer, you set up a soldering jig and replace the IREDs & IRXTRs and list them low to get rid of them.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 943
Joined: October 14th, 2013, 8:40 am

Re: 560 doing the 9 beep circle dance - BUT....

Postby vic7767 » May 16th, 2018, 5:54 pm

:cheers:
a1robotrepair wrote:list them low to get rid of them.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14627
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: im1kissfan, RockinRay, vic7767 and 366 guests