My Roomba does not detect connection to the docking base

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Re: My Roomba does not detect connection to the docking base

Postby mfortuna » May 28th, 2014, 7:33 am

No, the 400 series doesn't require the jack to be good, it uses diodes to "OR" the voltage. It could be the home base, the cable from the pads to the main board, or the main board.

If you have a meter, one way to check the voltage is remove the front bumper (4 screws and a connector), place the robot on the base, and measure voltage at the top of the pads.

If you see 22.5V or so at the pads the problem is the cable or main board, else the problem is the home base.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
Shark Ion 750
User avatar
mfortuna
Robot Master
 
Posts: 5815
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: My Roomba does not detect connection to the docking base

Postby finallyhere2005 » May 28th, 2014, 8:39 am

Great, thanks for the info. I'll try and scrounge up a meter.
finallyhere2005
 
Posts: 8
Joined: May 27th, 2014, 11:54 pm

Re: My Roomba does not detect connection to the docking base

Postby zygolux » November 9th, 2014, 6:13 am

Hello all,

One of my 2 Roomba 555 is having the same issue. I am far from being an electronic expert and expected to understand a bit more with the procedure posted by Bjorn ( http://hobbymechatronics.com/component/ ... the-roomba. ).
Unfortunately, the link seems to be dead.
Does someone have this procedure ?

Thanks.
zygolux
 
Posts: 3
Joined: November 9th, 2014, 5:53 am

Re: My Roomba does not detect connection to the docking base

Postby mfortuna » November 9th, 2014, 8:57 am

Take another look at page one of this topic. A picture shows which contact can be bent/cleaned. The bottom contact in the picture needs to touch the middle contact when the plug is removed.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
Shark Ion 750
User avatar
mfortuna
Robot Master
 
Posts: 5815
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: My Roomba does not detect connection to the docking base

Postby zygolux » November 9th, 2014, 9:25 am

Thanks Mike ! I think I understand now what I need to clean... I will try from the outside first with a screwdriver.
zygolux
 
Posts: 3
Joined: November 9th, 2014, 5:53 am

Re: My Roomba does not detect connection to the docking base

Postby zygolux » November 9th, 2014, 10:00 am

Done !!! My roomba 555 is able to charge again on the docking station. So happy as we would have had to buy a new one without this forum. Thanks a lot.
zygolux
 
Posts: 3
Joined: November 9th, 2014, 5:53 am

Re: My Roomba does not detect connection to the docking base

Postby meathead42 » May 6th, 2015, 10:10 pm

Thanks guys, this fixed my problem. You can order a power plug here as others have pointed out still. Works on the 581 model too!

http://www.ebay.com/itm/NEW-Roomba-500-Series-Power-Port-Plug-In-535-560-550-530-555-570-580-510-536-/200781450846?ssPageName=ADME:X:RTQ:US:1123
meathead42
 
Posts: 16
Joined: May 1st, 2011, 7:03 pm

Re: My Roomba does not detect connection to the docking base

Postby taylorash » January 20th, 2016, 12:01 am

Great post. I had this exact problem and ironically it happened after I was fiddling with sending commands to the serial port. Naturally, desperate to prove to my SO that the issue was unrelated I came across this thread and discovered my adapter port was exhibiting the same issue as outlined above. Since we always use the dock I opted to simply bridge pins 2 and 3 with solder, effectively making the dock always work and the adapter port never. If by chance the dock dies I can remove the solder bridge quickly enough. Also if in the future I need to order a bunch of parts from digikey I will replace the adaptor but for the time being I cannot justify $8 shipping for such a small item. Thanks.
taylorash
 
Posts: 1
Joined: January 19th, 2016, 10:41 pm

Re: My Roomba does not detect connection to the docking base

Postby a1robotrepair » January 23rd, 2016, 9:49 pm

I have them on eBay a1robotrepair
I also never plug the charger into the Roomba directly
My r3s and 700s have the black and brown wires cut and spliced going to the PCB via a small wire nut.
This disables the charging port on the Roomba. Splicing the brown and black wires and leaving the charging port active isn't advised as the charging plates will have the same voltage as the charger when the charger is plugged into the side.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 923
Joined: October 14th, 2013, 8:40 am

Just shorted the brown and black wires

Postby wocki » October 23rd, 2016, 5:29 pm

mechatronicsman wrote:
The brown and black wire are supposed to be connected inside the power connector of the Roomba when there is no charger plugged. And as soon as the charger is plugged this connection is broken. This ensures that plugging a charger directly, while the Roomba is charging in its home base, will disconnect the homebase charge circuitry (removing its ground connection).

However on my charge connector, this mechanism did not work, and the connection was permanently broken, even when the charge plug was removed. Therefore the home base charger input circuitry never had ground connection..

A little surgery, opening the connector, bending the parts into correct position, and closing the connector using epoxy solved it all.


Thank you ... I had the same problem. Just shorted the brown and black wires ... now roomba would charge at the docking station again. :thanks: :clap:
wocki
 
Posts: 2
Joined: October 23rd, 2016, 5:23 pm

Re: My Roomba does not detect connection to the docking base

Postby ePhYTesT » December 6th, 2016, 5:44 am

Hi just wnat to chime in, that I have also had success with fixing the jack on my Roomba 561 externally using a smal scrwedriver, just flicking the center plug a bit up and down.

Thank you all for contributing to this lifeextending solution for my Roomba!

Cheers
Mikael
ePhYTesT
 
Posts: 1
Joined: December 6th, 2016, 5:42 am

Re: My Roomba does not detect connection to the docking base

Postby S-F » December 7th, 2016, 1:52 pm

I just logged in to post the same question as Google gave me nothing when searching for "Roomba drives through dock" and the like and what do I see but this topic right up at the top. I bent the pin and blew in there and viola, it docks again!

Thanks everyone!
S-F
 
Posts: 18
Joined: May 24th, 2011, 5:18 pm

Re: My Roomba does not detect connection to the docking base

Postby Techbox » December 30th, 2016, 3:08 am

I'm pretty sure the problem is just dust and nothing to do with bending contacts although bending contacts is probably intrusive enough to dislodge any dust between the ground continuity contacts in the charging socket. When this happened to my Roomba 630 it was cured by depressing the ground contact on the charging socket and blasting some air duster into it. I've had the Roomba for a few years now and the problem never occurred until I used the charger directly into the Roomba (and thereby opening the contacts allowing dust to get between the contacts. The Roomba had discharged completely while the property was unoccupied for a few months and it had been left to do that last clean but I turned the charging station off as I do with most things when I'm working away. When I tried to recharge it, it wouldn't start charging on the charging station so I plugged the charger into the charging socket and it charged up ok. Subsequently it was OK on the charging station for a bit but the problem developed very soon after that. So, yes, I say depress the ground contact and blast it with air duster.
Techbox
 
Posts: 1
Joined: December 30th, 2016, 2:54 am

Re: My Roomba does not detect connection to the docking base

Postby TechGuy » June 7th, 2017, 10:26 pm

Sorry for double post. I repeat my post on this thread because this thread is part of a sticky thread on the iRobot Roomba and Scooba Chat forum.

There is a switch inside the side charging jack. The spring and the bottom contact closes when nothing is plugged in.
When the charger plug into the side jack, switch opens. Since the jack has a opening, dirt and debris gets inside the charging jack. When debris gets between the switch contacts, the switch is open and Roomba will think that it is being charged from the side jack and will not stay at home base to charge.

My simple fix is to get the switch contacts to close.

============================
Image
============================
Image
Charging battery directly: 400 Series, 500 Series,. How to Desolder
TechGuy
Robot Addict
 
Posts: 1543
Joined: February 17th, 2009, 11:52 pm

Re: My Roomba does not detect connection to the docking base

Postby pshuman » July 13th, 2017, 3:05 pm

My 500 series was also unable to charge from the dock. In my case, the barrel jack was not the problem. Instead, it was the orange three pin power connector between the barrel jack and the main circuit board. The physical connector had more wiggle than I would expect and one pin had black burn marks on the contacts and outside of the orange plastic, like it had been arcing.

I was able to use a multimeter to diagnose the lack of connection between the main circuit board and the plug. To resolve this problem, I cut the plug off the wire from the barrel jack and just soldered it straight to the pins off the circuit board, plus some heat shrink. Now we are docking again! :thumbup:

Thanks for all the details shared here that helped in my troubleshooting.
pshuman
 
Posts: 1
Joined: July 13th, 2017, 2:56 pm

Re: My Roomba does not detect connection to the docking base

Postby TechGuy » July 13th, 2017, 3:10 pm

Welcome to RR. You did a great job fixing your Roomba.
Charging battery directly: 400 Series, 500 Series,. How to Desolder
TechGuy
Robot Addict
 
Posts: 1543
Joined: February 17th, 2009, 11:52 pm

Re: My Roomba does not detect connection to the docking base

Postby rockitaway » July 14th, 2017, 8:57 pm

:thanks: I wanted to thank you all for posting this. This happened to each of my Roomba 595s last fall, and I was able to replace each of the charging jacks. :dance:

After it happened again a couple of months later, I replaced again and then put electrical tape over the power jacks. :idea: I haven't had any problems since. With three cats, forced air heating and home remodeling, my house does get pretty dusty quickly. :cheers:
rockitaway
 
Posts: 1
Joined: July 14th, 2017, 8:43 pm

Re: My Roomba does not detect connection to the docking base

Postby Rlegalv » November 23rd, 2017, 2:34 am

Thank you everyone for helping me with my Roomba. I was able to fix the problem by using a tiny screwdriver to push the connector on the side of my Roomba.

Regards!
Rlegalv
 
Posts: 1
Joined: January 31st, 2015, 8:46 pm

Just shorted the brown and black wires again !!!!

Postby wocki » December 16th, 2017, 1:38 pm

My second Roomba had the same problem -- the dilettante support team of Irobot demanded that I buy (from them) a new docking station -- which of course would have not resolved the docking problem.

I resolved it again by dismantling the manual plug and just shortenin the brown and black wires ;-)

I wonder how many people this problem have (I would suppose a lot ;-(

Is this malfunction a case of intended obsolescence?!
wocki
 
Posts: 2
Joined: October 23rd, 2016, 5:23 pm

Re: My Roomba does not detect connection to the docking base

Postby vic7767 » December 16th, 2017, 2:48 pm

wocki wrote:Is this malfunction a case of intended obsolescence?!
Nope, it's due to the cleaning environment and lots of dust and other debris building up in the jack opening. Get yourself a 90 degree 2.5mm power plug and insert it into the charger jack to prevent further damage.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14578
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

PreviousNext

Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: frensis, GraceL, Heraklen, magura, symbol, twistdh and 299 guests