Charging Error 3

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Re: Charging Error 3

Postby jeanm » September 22nd, 2017, 12:26 pm

Hello everyone,

Thank you for the precious information I found on this forum.

I own a roomba 630 which was stored for 2 years in the basement. When I tried to charge the battery, I got the charging error 3.

Following your advice and suspecting corrosion, I took a closer look at the motherboard. To my surprise, I found no corrosion but a hole in the VBAT sector and small damage on the GND.

I attached a picture of the motherboard. Is there anything to do?

IMG_0606 (2).jpg
Picture of the motherboard.


IMG_0059 (2).JPG
Zoom


Anyway, thanks in advance for your advice.
Jean
jeanm
 
Posts: 1
Joined: September 22nd, 2017, 12:17 pm

Re: Charging Error 3

Postby mfortuna » September 22nd, 2017, 3:11 pm

I don't think that is an issue. Just less than perfect soldering.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
Shark Ion 750
User avatar
mfortuna
Robot Master
 
Posts: 5831
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: Charging Error 3

Postby fabriciopk » June 1st, 2018, 5:28 pm

Hello everyone,

I had the same issue with U8 op-amp, when I turn on the robot it states charging error 3 always. But in my case, I think, was a lot worst. I tried to remove the IC and resolder it, but unfortunately I was unable to put it back because most of IC pad's were damaged by corrosion.

https://photos.google.com/share/AF1QipNFMP4PVE6Vk4Wo402h3NZQ_i7DAT4-RG78jP9PLQSk7ObcSbPg1ykxU2UbuMPnDg/photo/AF1QipO0OrUdE2ZGqipUiMptrlIbkZ94qwokssFDRiAD?key=OFczTnBLQkRBMHF4b3B1eGV0aU9iOVNnNndVejh3
fabriciopk
 
Posts: 1
Joined: June 1st, 2018, 5:14 pm

Previous

Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Alason, antekw2, Chonlameth, fuzzydunlop, im1kissfan, jdong, Miles267, RockinRay, sshephard, symbol, teokakav and 381 guests