Roomba discovery runs while charging battery

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba discovery runs while charging battery

Postby daffynca » December 6th, 2012, 1:33 am

Hi: I have a roomba discovery - when I plug the discovery in to charge the roomba discovery power light flashes and the brushes spin - the discovery doesn't actually try to move - just sits there an spins.

I'd really appreciate some input on what might be wrong with my roomba discovery.

Thanks in advance for your help and ideas!
Doreen
daffynca
 
Posts: 2
Joined: December 5th, 2012, 9:35 pm

Re: Roomba discovery runs while charging battery

Postby mfortuna » December 6th, 2012, 1:41 am

You have a transistor failure (U11) on your motherboard. U11 controls the brushes and in some failure cases it is on all the time (like a switch) and the brushes will turn unless the battery is dead or not being charged.

A new or repaired motherboard is the usual solution. The brush deck and motor usually needs attention as well.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
User avatar
mfortuna
Robot Master
 
Posts: 5218
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: Roomba discovery runs while charging battery

Postby vic7767 » December 6th, 2012, 1:45 am

That Roomba may have a defective U11 (6 pin) device. It can be removed and then replaced with a 3 pin FET if the PCAB has the FET trace. Here is a URL to a picture of the replacement process: http://www.robot-doc.com/29.html
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 11930
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Roomba discovery runs while charging battery

Postby mfortuna » December 6th, 2012, 2:06 am

I have had two Reds and a Disco suffer this failure after many years of service. All three had brush deck issues as well. Just replacing U11may not be enough. In my case all three brush decks needed repair including motor replacement on two of them. All three needed cleaning and gear replacements. The Discovery was retired and is used as a spare parts source because of other issues, the other two robots are still in use thanks to a more capable U11 replacement transistor and vic7767's bearing kits.

One of my reds is used weekly and the other is run once a month. Both are now 6+ years old and still running after repair.

I think the Discovery and similar (Reds/sage/dirt dog) are some of the best Irobot products ever. I will keep mine running before updating. My guess is the 900 series will be my next purchase. :)

Anyway, if replacing transistors and maybe gears is in your comfort zone your robot is worth fixing. If not try to find a cheap 500 series replacement. And eventually add bearings to the CHM.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
User avatar
mfortuna
Robot Master
 
Posts: 5218
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: Roomba discovery runs while charging battery

Postby daffynca » December 6th, 2012, 5:18 pm

Thank you for the responses - I'm not too sure I'm comfortable with transistors and gears - but what do I have to lose other than some time and potential of not being able to get my roomba operational again ?? Is there a tutorial or guide that can walk me through what I'd need to do to replace the UII or the motherboard ?

Thanks again!
Doreen
daffynca
 
Posts: 2
Joined: December 5th, 2012, 9:35 pm


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: 911medic, Fraggboy, johnnyh, vic7767 and 185 guests