AUS Roomba 650 vacuum/AeroVac bin is always on

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

AUS Roomba 650 vacuum/AeroVac bin is always on

Postby StygianBeast » December 27th, 2012, 4:29 pm

Hi all,

Just opened a brand new Roomba 650 and upon removing the battery tab the vacuum/AeroVav came on.

The vacuum is on when the Roomba is on, when the Roomba is off, after docking, while charging, all the time. The vacuum only stops if I remove the battery or the dust tray.

I did a software reset using the dock/spot buttons. I removed the battery several times. All to no avail.

Whenever the battery is connected there's a current on the AeroVav contacts.

Has anyone had this problem before?
StygianBeast
 
Posts: 2
Joined: December 27th, 2012, 3:54 pm

Re: AUS Roomba 650 vacuum/AeroVac bin is always on

Postby vic7767 » December 27th, 2012, 6:15 pm

There is a driver transistor that has failed on the main mobo of your Roomba. If under warranty return it for a replacement.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 11882
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: AUS Roomba 650 vacuum/AeroVac bin is always on

Postby StygianBeast » December 27th, 2012, 7:21 pm

Thanks vic7767, that makes sense.

It'll take forever for the replacement to get here, I might replace the transistor myself...
StygianBeast
 
Posts: 2
Joined: December 27th, 2012, 3:54 pm


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: NeatoReid, TechGuy, vic7767 and 164 guests