780 constant tangle error

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

780 constant tangle error

Postby riquez » October 2nd, 2013, 5:37 am

We have only had the Roombo 780 for 3 weeks & today it seems to have broken :-(

The robot went under a table & there were a couple of power cables which it may have got tangled in, but we are not entirely sure.

Here is what happened:
1) The robot was cleaning a small room. It finished cleaning & played it "doo dee doo, ive finished tune"
2) My wife went into the room, the robot was under the table, she pulled it out & noticed that a power cable moved - so it was touching the cable, but it wasnt tangled. There was no error lights or anything.
3) She placed the robot in another room & pressed start - the tangle error light came on.
- The robot appears to still work, but the side brush does not function at all & the error light is always flashing.

She checked & cleaned the robot, replaced the brush, used canned air & reset it - none of these have helped.

What could the problem be?
riquez
 
Posts: 7
Joined: September 9th, 2013, 9:59 am

Re: 780 constant tangle error

Postby piokrza » October 2nd, 2013, 6:29 am

Have you disassembled the side brush to clean it up from tangled hairs? Beside red light error indicator it can play tune or voice notification - have you notice such thing? User manual explains it.
piokrza
Robot Master
 
Posts: 3460
Joined: May 18th, 2009, 8:17 am
Location: Poland

Re: 780 constant tangle error

Postby Roombascoobatastic » October 2nd, 2013, 6:38 am

Just head over to iRobot's support page (link below) and fill out the form. They will contact you by e-mail within hours and ask for your permission to send out a replacement side brush module at no cost.

http://homesupport.irobot.com/app/ask/s ... V1RNQmw%3D
Sincerely,

Rick
User avatar
Roombascoobatastic
Magazine Editor
 
Posts: 286
Joined: May 12th, 2013, 1:36 am
Location: Canada

Re: 780 constant tangle error

Postby vic7767 » October 2nd, 2013, 3:01 pm

You can also check out the side brush motor you have by removing it from the Roomba and use a 9 volt battery pressing the battery directly to the two contacts of the brush motor. If the motor spins then reverse the polarity and see if the motor spins in the other direction. If the motor works in both directions then there may be a hardware fault internal to the 780 sidebrush H-bridge. Either way since your Roomba is under warranty contact iRobot for support or replacement.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14779
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 780 constant tangle error

Postby mass » January 3rd, 2014, 10:38 am

Hi,

My 780 roomba is doing the exact same thing.
In my case was after I clean it up (strange)!

Did you manage to solve this?

Turning the roomba upside down and inspecting the several parts, looks like the left wheel is a little bit stuck (comparing with the right wheel).
Does anyone know if this can be easily disassembled?

Thank you
mass
 
Posts: 3
Joined: January 3rd, 2014, 10:32 am

Re: 780 constant tangle error

Postby vic7767 » January 3rd, 2014, 11:26 am

mass if you remove the side brush motor you can test it with a 9 volt battery as mentioned above. If it doesn't work you can order a new replacement module for $15.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14779
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 780 constant tangle error

Postby mass » January 3rd, 2014, 2:58 pm

Hi,

Thanks vic7767 for the fast reply.

I tried that and the motor works fine, in both directions!

There is one more thing my roomba started to do.
When I press the start button it says:
"Error 1. Left"

Anyone had that?

Cheers,
MASS
mass
 
Posts: 3
Joined: January 3rd, 2014, 10:32 am

Re: 780 constant tangle error

Postby Markrose » January 3rd, 2014, 3:43 pm

Error one is the wheel being stuck error. Left meaning the left wheel. Something has happened to the left wheel. Replace the left wheel module by purchasing a left wheel module, removing the two screws, putting the new module in, and re-tightening the screws. The wheel issue should be resolved.
My 'bots: Roomba 620, Neato Robotics Botvac 80.
User avatar
Markrose
Robot Addict
 
Posts: 160
Joined: June 8th, 2013, 4:44 am

Re: 780 constant tangle error

Postby vic7767 » January 3rd, 2014, 4:27 pm

mass wrote:Turning the roomba upside down and inspecting the several parts, looks like the left wheel is a little bit stuck (comparing with the right wheel). Does anyone know if this can be easily disassembled?


Are you asking about taking the wheel apart or just how to remove the wheel module from your Roomba ?

To remove the wheel module first remove the side brush then loosen the 4 phillips head screws from the base plate and lift it off, that action will reveal the two screws that you need to loosen and lift out that left wheel. To learn how to test as well as dis-assemble that wheel scroll down towards the bottom of this page:

http://www.vic7767.com/how-do-i/
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14779
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 780 constant tangle error

Postby mass » January 10th, 2014, 11:54 am

Hi guys,

Back to tell my story!

Like riquez, my Roomba is almost new, so I contacted customer service.
They told me to ensure that when assembling the side brush, to press it hard and hear a "click".
If that doesn't worked, then I should contact them again to schedule a pick up for the roomba.

Arriving home, pressed the side brush and "click". The side brush was not well inserted.
Turning on, crossed my fingers but the error still persists.
I locked at the web page that vic7767 wrote (thank you vic7767, a web page very well writen and good photo coverage, congratulations for that), but I must say I was afraid when I saw all that small wheels (I was afraid I damage something and lose the warranty).

Because it was friday evening I had to wait for monday morning to schedule the pick up.
But on monday morning, the roomba start spinning the side brush, stop saying it as an error or that it is tagled on something.

Not sure what exactly happend were. Maybe the Roomba started with the error because I didn't assembly correctly the side brush after the cleanup.

Anyway, it appears fixed, thanks everyone for the help.

CONCLUSION: If anyone as this problem make sure to press hard when assembling the side brush and give one or two cycles to reset the error.

Hope it helps anyone.

Cheers,
MASS
mass
 
Posts: 3
Joined: January 3rd, 2014, 10:32 am

Re: 780 constant tangle error

Postby vic7767 » January 10th, 2014, 1:17 pm

The side brush is just a small module assembly that can be removed and replaced without having to replace the complete robot. To test whether it is the side brush module or the Roomba just remove the side brush module and run the Roomba for a short time and observe whether the Roomba continues to complain. If the error continues even with the side brush removed then you have a Roomba fault. If the Roomba runs well then you have a side brush motor fault and it is normally due to hair buildup around the gear shaft that the sidebrush attaches to. The anti-tangle error is detected from monitoring the current the motor draws and when excessive triggers the error.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14779
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: 780 constant tangle error

Postby cafa90 » March 27th, 2016, 5:19 am

I got the same problem,the Roomba runs fine but as it goes the anti angle icon will flash ,and the side brush will just spin two circle then stop and go backwards before continuing in the right direction again. I tried to clean the side brush motor and CHM,but situation still the same.I also used roomba self test , CHM and side brush work fine.
SO how could i solve the problem?
cafa90
 
Posts: 2
Joined: March 27th, 2016, 5:03 am

Re: 780 constant tangle error

Postby mfortuna » March 27th, 2016, 8:21 am

As mentioned try running it without the side brush assembly to verify that is the issue. You may have to take it apart to clean it. A lot of time debris builds up between the brush and the rest of the assembly. You need to remove the brush. If the side brush still causes problems remove it for good or replace it. IMHO you really don't need a side brush.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
Shark Ion 750
User avatar
mfortuna
Robot Master
 
Posts: 5833
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: 780 constant tangle error

Postby cafa90 » March 27th, 2016, 8:28 am

I have been removed side brush and let roomba ran,but anti angle icon still flash.
cafa90
 
Posts: 2
Joined: March 27th, 2016, 5:03 am

Re: 780 constant tangle error

Postby mfortuna » March 27th, 2016, 6:16 pm

Did you remove the entire side brush module?
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
Shark Ion 750
User avatar
mfortuna
Robot Master
 
Posts: 5833
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: 780 constant tangle error

Postby Teilchen » July 29th, 2018, 7:52 am

Any progress on the root cause?
Teilchen
 
Posts: 5
Joined: July 26th, 2018, 5:56 am

Re: 780 constant tangle error

Postby a1robotrepair » July 29th, 2018, 1:10 pm

The Cleaning Head Module can cause this problem also.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 949
Joined: October 14th, 2013, 8:40 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: anjosva, ASTMedic, jramer, mfortuna, teokakav and 304 guests