Problem with Roomba 780 and RCON sensor

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Problem with Roomba 780 and RCON sensor

Postby togarha » December 4th, 2016, 10:42 am

Hi!
I have some problems with roomba 780, suddently the remote control starts to fail and it starts to clean worse than usually. The remote works fine, green led blinks when pressing some button and the IR transmitter works (or at least it sends something).
I made some checkings (remove the battery, etc) and the remote works, but only the first or second time. After that, it doesn't work another time.
Today I discovered this webpage and I found how to make Built In Tests, I tried to pass some tests, and almost all passed fine (I stop passing tests when I arrived to power tests). Really, all tests passed except RCON test. I tried it pressing forward button in remote, with Virtual Wall and with Dock. None of them works. The following test (Front directional IR receivers / binoculars) works fine.
After resetting some times the Roomba, now it seems that it works fine with the remote, but the RCON built in test continues without passing.
- Which is the difference between the RCON and the directional IR receivers?
- Where could be the problem for the remote control when sometimes works and other it doesn't?

Thanks in advance...
BR,
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby vic7767 » December 4th, 2016, 11:32 am

A common fault is for the 3 wire cable that connects the RCON to the main board is broken (caused by poor placement of the cable). Remove the front bumper and inspect the wiring.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14303
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Problem with Roomba 780 and RCON sensor

Postby TechGuy » December 4th, 2016, 5:25 pm

togarha wrote:...
I made some checkings (remove the battery, etc) and the remote works, but only the first or second time. After that, it doesn't work another time.
...

Just to point out the obvious...
How old are the batteries in your remote?
Charging battery directly: 400 Series, 500 Series,. How to Desolder
For Sale: Black CHM 2 Ball Bearings set
User avatar
TechGuy
Robot Addict
 
Posts: 1491
Joined: February 17th, 2009, 11:52 pm

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » December 4th, 2016, 5:29 pm

TechGuy wrote:
togarha wrote:...
I made some checkings (remove the battery, etc) and the remote works, but only the first or second time. After that, it doesn't work another time.
...

Just to point out the obvious...
How old are the batteries in your remote?

I think we misunderstand ourselves, I didn't remove the battery of the remote, I remove the battery of the roomba. The remote works fine, the problem is inside roomba...
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » December 4th, 2016, 5:31 pm

vic7767 wrote:A common fault is for the 3 wire cable that connects the RCON to the main board is broken (caused by poor placement of the cable). Remove the front bumper and inspect the wiring.

Thanks for your comment, I will check it...
If the cable is broken, it only affects to the remote control communication or it can make other things fail?
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby vic7767 » December 4th, 2016, 5:47 pm

The Roomba Confinement sensor is also used to help detect the home base.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14303
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Problem with Roomba 780 and RCON sensor

Postby Kelad » December 4th, 2016, 7:48 pm

re: trying to pass test "factory-test 9 omni-receiver (rcon?)"

see my question and Vics response which worked for me in post below

http://www.robotreviews.com/chat/viewtopic.php?f=1&t=15192&p=138512#p138512
Kelad
Robot Groupie
 
Posts: 67
Joined: February 19th, 2015, 4:50 am
Location: Australia

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » December 5th, 2016, 3:51 pm

Kelad wrote:re: trying to pass test "factory-test 9 omni-receiver (rcon?)"

see my question and Vics response which worked for me in post below

http://www.robotreviews.com/chat/viewtopic.php?f=1&t=15192&p=138512#p138512


I tried with both things, remote and VW, but none of them works...
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby vic7767 » December 5th, 2016, 4:19 pm

Have you removed the bumper and checked the wires?
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14303
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » December 5th, 2016, 7:25 pm

This afternoon I have disassembled it and I found one of the wires pinched, it didn't seem to be totally cutted, but it could be.
I haven't changed it because there are 4 triangular screws that fix the last plastic to the PCB and I couldn't remove it, I need to find a triangular screwdriver to remove it and change the wire.
I haven't checked if the IR receiver works fine, as it works from time to time I suppose that it works fine and depending of the position of the wire, it works or not...
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » December 26th, 2016, 10:08 am

Finally I was able to disassembly the protector with triangle screws and arrive to the PCB.

I just repair the wires and check it with the multimeter and there is full connectivity between the sensor and the pcb connector, but the RCON sensor still doesn't work.

I suppose that the problem is in the IR receiver sensor, anybody knows the reference of the electronic part, or any equivalent?

Thanks,
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » January 10th, 2017, 2:56 pm

I just made another thing, I remove the IR sensor, disassembly from the wires and connect to a 5V power supply.
I check with the oscilloscope that both the remote and the virtual wall works fine, of course the IR sensor works fine too (if not I have no idea if the remote and the vw are working)...

Any idea about where is the problem?
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby togarha » January 18th, 2017, 3:59 pm

Finally, after re-solder the ir sensor another time to the wires, put it in its position and resetting roomba, everythings seems that works fine with rcon sensor and remote.

Thanks for your help
togarha
 
Posts: 8
Joined: December 4th, 2016, 10:03 am

Re: Problem with Roomba 780 and RCON sensor

Postby foster182 » August 8th, 2017, 8:24 pm

Hey there, i'm in a similar situation, only the Dock and the VW seems to be working fine.
But the remote doesn't seem to be working with the roomba.

it's an IR remote, and it definitely sending an IR signal, i can see the led flash using my camera phone, plus i'm able to capture the IR signal with my logitech remote.

Any idea's what could be the problem?

I've opened the roomba and cleaned all internals, and checked the IR sensor. Doesn't seem to have any broken wires, even checked continuity from pin leg to PCB board.

Thanks
foster182
 
Posts: 2
Joined: August 8th, 2017, 8:14 pm

Re: Problem with Roomba 780 and RCON sensor

Postby vic7767 » August 9th, 2017, 2:39 pm

foster182 wrote:the remote doesn't seem to be working with the roomba.
You might run the Built in tests to help determine if your RCON sensor is receiving the Remote IR commands.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14303
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Problem with Roomba 780 and RCON sensor

Postby foster182 » August 10th, 2017, 7:05 pm

vic7767 wrote:
foster182 wrote:the remote doesn't seem to be working with the roomba.
You might run the Built in tests to help determine if your RCON sensor is receiving the Remote IR commands.


Any idea how to do that?

Thanks
foster182
 
Posts: 2
Joined: August 8th, 2017, 8:14 pm

Re: Problem with Roomba 780 and RCON sensor

Postby vic7767 » August 10th, 2017, 7:35 pm

Head over here and glean through this thread: viewtopic.php?f=1&t=2757
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14303
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Metalworker, TechGuy and 348 guests

cron