Irobot series 630 brushes not turning

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Irobot series 630 brushes not turning

Postby Annette17 » January 10th, 2017, 3:01 am

Please help!! The under brushes on myRoomba 630 not turning. I have given it a thorough clean and it is still not working. I have done a reset also. I just ran a diagnosic test and the brushes did not move when tested. Does anyone have advice as to what might be the problem and how to fix it?
Annette17
 
Posts: 3
Joined: January 10th, 2017, 2:48 am

Re: Irobot series 630 brushes not turning

Postby someoneclever » January 10th, 2017, 4:20 am

Replace CHM?


Sent from my iPhone using Tapatalk
someoneclever
Robot Addict
 
Posts: 107
Joined: October 11th, 2016, 12:30 pm

Re: Irobot series 630 brushes not turning

Postby Kelad » January 10th, 2017, 5:03 am

I reckon before replacing the Cleaning Head Module a few more checks should be done.
1) remove and inspect the CHM - Is the CHM full of fluff which surrounds the motor?
2) remove and inspect the CHM gearbox - are the gears clean or full of dirt ?
3) redo built in tests with the gearbox disconnected -> same result ?
4) remove motor gearbox and inspect
5) redo built in tests with the motot gearbox disconnected -> same result ?
6) use 9V battery to run the CHM outside the robot

If possible, maybe you have a friend and you can try their CHM in your robot.

Doing the above is not a waste of time as you will learn about your roomba....
Kelad
Robot Groupie
 
Posts: 67
Joined: February 19th, 2015, 4:50 am
Location: Australia

Re: Irobot series 630 brushes not turning

Postby Annette17 » January 10th, 2017, 5:14 am

This may seem like a dumb question but does the CHM turn? As mine is not turning.
Annette17
 
Posts: 3
Joined: January 10th, 2017, 2:48 am

Re: Irobot series 630 brushes not turning

Postby Annette17 » January 10th, 2017, 5:16 am

I cleaned the gear box and that fixed the screeching problem but brushes still not turning.
It's seems that the cogs are not moving so does this mean it's time to replace the CHM?
Annette17
 
Posts: 3
Joined: January 10th, 2017, 2:48 am

Re: Irobot series 630 brushes not turning

Postby Kelad » January 11th, 2017, 1:26 am

Annette17 wrote:This may seem like a dumb question but does the CHM turn? As mine is not turning.

The CHM or cleaning head module compromises of the:
- brush motor + motor gearbox
- brush gearbox
- 2 x brushes
- dirt detect sensor
- housing

Annette17 wrote:I cleaned the gear box and that fixed the screeching problem but brushes still not turning.
It's seems that the cogs are not moving so does this mean it's time to replace the CHM?

which gearbox did you clean and more info about the screeching problem please.
Kelad
Robot Groupie
 
Posts: 67
Joined: February 19th, 2015, 4:50 am
Location: Australia

Re: Irobot series 630 brushes not turning

Postby off-road-biker » January 11th, 2017, 9:02 am

@Annette17
Would be best to post a video here.
Roomba 560 with 700 ECHM (grey) and modded original vac bin (R3)
User avatar
off-road-biker
 
Posts: 22
Joined: December 30th, 2016, 12:12 am
Location: Germany


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: aarolar, Metalworker, RobotJunkie30, Snokia, susantx3, vic7767, Wing Nut and 425 guests