Roomba 530 dead capacitor x1 ?

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 530 dead capacitor x1 ?

Postby John-sausage » July 9th, 2017, 4:26 am

Hi,

i bought a second hand roomba which was broken with error code 3.

I opened, and it doesn't seems to be a battery leak issue, Q17/Q18 and U8 are clean.

However, in the bottom right corner of the motherboard, i think a capacitor died, as you can see on the picture attached.
19840516_10154582902757026_980147377_o.jpg


Can anyone confirm that it could be the source of the issue? What can i use to replace the component?

Thanks in advance for any help you can provide, i'm a beginner at this stuff, maybe it's a very common component?
John-sausage
 
Posts: 4
Joined: July 9th, 2017, 4:18 am

Re: Roomba 530 dead capacitor x1 ?

Postby John-sausage » July 9th, 2017, 5:13 am

i found the same companent online i think. Should i just clean a bit around, solder the new one? is there another check i can do?
John-sausage
 
Posts: 4
Joined: July 9th, 2017, 4:18 am

Re: Roomba 530 dead capacitor x1 ?

Postby mfortuna » July 9th, 2017, 7:01 am

if you are referring to the silver object in the center of the picture that is a crystal and the gunk is what glues it to the board. There is probably nothing wrong with it.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
User avatar
mfortuna
Robot Master
 
Posts: 5759
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: Roomba 530 dead capacitor x1 ?

Postby a1robotrepair » July 9th, 2017, 11:27 am

x1 is a crystal oscillator. Caps are labeled C(no.).
BIT 11 will tell you the problem.
Spot LED on: Battery voltage between 12 and 18VDC. U8 A2.
Dock LED on: Thermistor Present. U8 A3.
Check Robot LED on: Baseline Current OK. U8 A1 and A4.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 530 dead capacitor x1 ?

Postby John-sausage » August 6th, 2017, 5:54 am

thank you a1robotrepair, your directions are greatly helping me finding the issue!

Fixed the x1 crystall oscillator.
Now i get error 3...
Run the Bit tests, all passings...
BIT 11: spot and dock green, check robot off.
So i was thinking, could it be the charger? i checked the voltage on the charger pad without the robot, and have a reading of 28V, that seems a bit much?
John-sausage
 
Posts: 4
Joined: July 9th, 2017, 4:18 am

Re: Roomba 530 dead capacitor x1 ?

Postby a1robotrepair » August 6th, 2017, 7:24 am

I will assume that your description of "charger pad", you mean the charging base charging plates.
Check again, without load they will read around Two point Eight volts DC.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 530 dead capacitor x1 ?

Postby John-sausage » August 6th, 2017, 11:00 am

yep you're right.
not sure where to look for now. i also tried with a new battery, with same result.
John-sausage
 
Posts: 4
Joined: July 9th, 2017, 4:18 am

Re: Roomba 530 dead capacitor x1 ?

Postby a1robotrepair » August 6th, 2017, 1:57 pm

Check out this thread:http://www.robotreviews.com/chat/viewtopic.php?f=1&t=19964and associated threads.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Aniseedvan, Atena, vic7767 and 290 guests