Roomba 581 - Working, but wont charge

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 581 - Working, but wont charge

Postby zonax_ » July 13th, 2017, 9:53 am

Hello guys,

First post here. I've been reading and reading for days now, and have not found the answer to my problem, as mine is a bit different than others.

Here it goes:

I have 3 Roombas, one that works great, one that does not work at all (No light or anything), and then the 581 that works, but wont charge.
I'm trying to figure out why it wont charge. If I'm taking the battery from the one that works, it is doing it's job and are happy, until it needs to charge it. It finds the dock and the charging light(Orange slow pulsing) turns on. But from there nothing happens. Well, tried a lot of things, and most of the times it goes green, and when taking it for a clean, it just dies instantly. So Roomba thinks the battery is charged, but it isn't. Sometimes it gives me the error5.
I then tried to charge my battery with the roomba that works, put it back in the 581 and then go into debug mode. I ran all the 26(i think) tests, and they all worked EXCEPT when it came to the charging. It failed on all of those tests. Both with the dock and directly connected.

I even ordered two new batteries, as the old ones were getting bad, same problem still. I've also measured the voltage from the power supply, and it reads 22.5v.

So here is what I know so far:
- My roomba seems to be working perfect, except when it needs to charge.
- The power supply is working. (Even tried with another power supply, same issue)
- Batteries are working (Tested it on the roomba that works).


So I'm thinking it must be something on the motherboard. I'm not really good with electricity, but have a voltmeter, and can solder. And that's where the third roomba comes in handy. If I could somehow figure out that was wrong, I could try replacing it with spare parts from the third roomba.

I've also read this, that reminds of my problem. But then not. It's working, and is not blinking orange, when it is not charging. viewtopic.php?t=14395

So what should my next step be? What can I measure to figure out what is wrong?

Best regards, Jesper.
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby TechGuy » July 13th, 2017, 11:38 am

Can you charge your 581 battery by plugging in at the side jack?
Charging battery directly: 400 Series, 500 Series,. How to Desolder
For Sale: Black CHM 2 Ball Bearings set
User avatar
TechGuy
Robot Addict
 
Posts: 1493
Joined: February 17th, 2009, 11:52 pm

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 14th, 2017, 7:02 am

Hi TechGuy, thanks for helping out.

I can't charge it, neither with the dock or the jack. The last two days it's been giving me an error 5, after I would say 30 minutes. I've read somewhere, that it could be that the amps are below 400mA.

I'm sure it has nothing to do with the dock, or the powersupply, as my other robot works well on both (I have 2 psu+dock)
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby vic7767 » July 14th, 2017, 11:17 am

Although less failures of the charging MOSFETs are reported in the 500 series of Roomba they still fail from time to time.

If you can monitor the SCI port while charging is attempted you will be able to determine if the charging MOSFETs are failing because the charging current reports will show a negative milliamp value.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14330
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Roomba 581 - Working, but wont charge

Postby TechGuy » July 14th, 2017, 11:51 am

Another check is to examine the 4 spring contacts at the bottom of battery well.
Is there any sign of corrosion from leaky battery?
If yes, clean it.
Pull up the spring up a bit to ensure the spring contacts to have good contact with the battery.
Install battery again and test it.

But monitoring the SCI port, suggested by vic7767, will give you the final answer whether you need to repair or replace your PCA or not.
Charging battery directly: 400 Series, 500 Series,. How to Desolder
For Sale: Black CHM 2 Ball Bearings set
User avatar
TechGuy
Robot Addict
 
Posts: 1493
Joined: February 17th, 2009, 11:52 pm

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 14th, 2017, 2:01 pm

Just tried cleaning and pull the springs up, and even put some paper between the battery and the shell, to be sure they had contact. There was no corrosion or anything. After 30 minutes of charging it said Error 5 again.

I do not have the tools to monitor the SCI port (DIN to USB right?), is there any other way to measure the MOSFET, or should I order a cable?
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby vic7767 » July 14th, 2017, 2:42 pm

Not familiar with the electrical characteristics to walk through the MOSFET tests in the 500 Roomba. However, you can order the iRobot Create 2 cable accessory and use that to connect your Roomba. That cable consists of a male 7 pin MINI Din connector wired to a USB UART.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14330
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Roomba 581 - Working, but wont charge

Postby a1robotrepair » July 14th, 2017, 2:47 pm

Yes, it requires removing the front bumper, top trim, buttons cover and chassis cover and a voltmeter.
Read this thread: http://www.robotreviews.com/chat/viewtopic.php?t=15704&p=137432#p137432
Use the charger plugged directly into the bot.
Look at the drawing in that thread and check for 22VDC at the charging plug connector, red to black then brown wire connections, then red to GND...SysRtn R257//R235. If you have 22V there -V system OK.
Keep negative lead on SysRtn or GND and check for 22VDC on both sides of FB2 then F2 then D58 then Q17 source then drain Q18 source then drain then VBAT.
Red indicates devices located on bottom of board.
At some point you will read VBAT (14 to 16VDC) along that chain. The device that has 22VDC on one side and 14 to 16 VDC on the other will point to where the problem is. With a charged battery will the bot run normally?
Assuming you have a good battery.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 14th, 2017, 3:47 pm

a1robotrepair:
If I charge the battery on my other bot, and then put it in the 581 it will do a normal cleaning cycle.

I'll try to measure it, but seems fairly advanced. But I'm giving it a try.
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 16th, 2017, 8:47 pm

Power jack plug:
Black to red: 22.4v
Brown does not give anything. Is that ground? (The powersupply does not have ground)

GND to R257: 22,4v on both sides
GND to R235: 22,4v on both sides
(What is SysRtn?)

GND to FB2: 22,4v on both sides

GND to F2: 22,4v on both sides
GND to D58: 22,4v on negative side, and 21,7v on the plus side (There is a plus on that side)

Attached is the Q17 and Q18 readings, as I don't know what is drain, vbat etc.
http://imgur.com/xn6Htkt (I got an error while trying to upload it here, so i just uploaded it on imgur)
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 18th, 2017, 6:26 pm

Can it be the D58 there is the problem, or is the voltage okay on this?
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby a1robotrepair » July 18th, 2017, 7:40 pm

Diode is fine. Your problem is neither FET Q17 or Q18 is turning on.
FET data sheet: http://www.mouser.com/ds/2/115/ZXMP6A17G-77699.pdf
Leftmost solder pin on both FETs is the gate, must be lower than source, rightmost pin.
Drawing in this thread: http://www.robotreviews.com/chat/viewtopic.php?t=15704&p=137432#p137432
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby a1robotrepair » July 18th, 2017, 7:46 pm

Wait a minute! Is there a battery in it? Run the good battery down in either bot and put it in this one uncharged.
The middle pin, top pin of Q18 should read battery voltage from GND, the same as from VBAT to GND.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 20th, 2017, 11:41 am

You are right -The battery was not in. I made it clean, and then tried again:

These masuremenets is with a drained battery (Red light - Voice says I need to charge it):
GND to VBAT = 11,9v

Q17:
GND to LEFT PIN: 10,8v
GND to MIDDLE PIN: 11,3v
GND to RIGHT PIN: 11,1v
GND to TOP PIN: 11,3v

Q18:
GND to LEFT PIN: 11,1v
GND to MIDDLE PIN: 11,9v
GND to RIGHT PIN: 11,3v
GND to TOP PIN: 11,9v




These masuremenets is with a drained battery AND PLUGGED IN CHARGER:
GND to VBAT = 11,6v

Q17:
GND to LEFT PIN: 01,1v
GND to MIDDLE PIN: 11,5v
GND to RIGHT PIN: 11,5v
GND to TOP PIN: 11,5v

Q18:
GND to LEFT PIN: 01,1v
GND to MIDDLE PIN: 11,4v
GND to RIGHT PIN: 11,4v
GND to TOP PIN: 11,4v
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby a1robotrepair » July 20th, 2017, 12:26 pm

You need a better meter.
These readings indicate that your battery is charging.
Do you still get CE5?
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby a1robotrepair » July 20th, 2017, 12:53 pm

Replace the battery, batteries in your meter.
Why I think your meter is off, robot off with drained battery should read 13V at least.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 21st, 2017, 5:30 am

I don't think it's my battery in my meter. The voltage is actually that low. I just tried measuring it again today, now only 6,xv. Just tried to put it in my other robot. It starts the 16 hour charging, which makes me believe that the broken robot does something weird, to drain the battery "more that it should".
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby a1robotrepair » July 21st, 2017, 7:13 am

Your FETs are working correctly but current isn't getting from the charger to the battery.
The most obvious problem would be D58.
To verify, while charging check voltage on both sides of D58 to SysRtn or GND. Should be the same. If higher, 21V on one side, charger side, and VBAT on the other, battery side, change D58.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 796
Joined: October 14th, 2013, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby zonax_ » July 22nd, 2017, 4:26 am

Changing the D58 did the trick. :-) I would like to thank you so much for all the help you have been giving!
zonax_
 
Posts: 9
Joined: July 13th, 2017, 8:40 am

Re: Roomba 581 - Working, but wont charge

Postby JackMayyam » July 22nd, 2017, 4:57 am

I have had an error 5 before. turns out that something has obstructed the battery contacts. This should help you as it fixed mine. Hope you'd be able to fix yours soon!!
Last edited by JackMayyam on August 31st, 2017, 1:47 am, edited 1 time in total.
User avatar
JackMayyam
 
Posts: 7
Joined: July 18th, 2017, 10:34 pm

Next

Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: aarolar, chefkeith, TechGuy, Tenergy, vic7767 and 368 guests