Page 2 of 2

Re: Roomba 581 - Working, but wont charge

PostPosted: December 6th, 2018, 3:52 pm
by felixxx
Hi.
I see this post and I have similar problems with my roomba 581.
Symptoms are:
it won't change on docking station. It keeps to try dock, but he don't recognise station. If I plug psu directly into roomba it change perfectly.
What I try to solve this. I try it with other docking, with other battery and the problem won't go away.
I open roomba and wire psu from docking station directly to the main board and it wont charge. Green light on dock keeps blinking. It should go solid when roomba is dock and start charging.
Can anyone help me out here with this? What can do?

Re: Roomba 581 - Working, but wont charge

PostPosted: December 6th, 2018, 6:33 pm
by leonicholson
Check this. I replaced the charging jack on a Roomba 595 that was acting the same way. Easy fix.
viewtopic.php?f=1&t=20463

Re: Roomba 581 - Working, but wont charge

PostPosted: December 6th, 2018, 11:48 pm
by Brett
You do not need to replace it - just clean it.

Here are some previous references to what to do...

(-8

Re: Roomba 581 - Working, but wont charge

PostPosted: December 7th, 2018, 10:09 am
by leonicholson
Brett wrote:You do not need to replace it - just clean it.

I certainly concur with first trying to fix by cleaning.
The cleaning steps didn't work out for me, so I did have to replace the jack.
Replacing the part is a last resort, but inexpensive and doable.

Re: Roomba 581 - Working, but wont charge

PostPosted: December 7th, 2018, 2:00 pm
by felixxx
Brett and leonicholson
You make my day...I just clean it and now it works like it should...thanks

Re: Roomba 581 - Working, but wont charge

PostPosted: December 11th, 2018, 6:43 am
by Serge_ISA

Re: Roomba 581 - Working, but wont charge

PostPosted: December 12th, 2018, 1:38 pm
by a1robotrepair
Above is not recommended as charger potential will be on charging plates when the charger is plugged into the bot, possibly shorting the charger and damaging the bots charging system.
Better to cut the brown and black wires, shorting them together on the bot connector side and just removing the connector. Tape the red wire end for safety.