5 year old 650 not charging

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

5 year old 650 not charging

Postby JiminSTLouis » January 1st, 2018, 12:03 am

Hello

My daughter borrowed our 650 for a couple of years and I just took it back today. It looked liked it was never cleaned or the bin emptied. After a thorough cleaning, I tried charging it and after about a half an hour, I received a charging error 5. All charging contacts are clean including the battery compartment contacts. I did a reboot by holding down the spot/dock buttons but still get the error. Is the battery ready to be replaced or is there something else I can try?

Thanks
JiminSTLouis
 
Posts: 13
Joined: December 27th, 2012, 1:56 pm

5 year old 650 not charging

Postby DeanR181 » January 1st, 2018, 12:12 am

JiminSTLouis wrote:Hello

My daughter borrowed our 650 for a couple of years and I just took it back today. It looked liked it was never cleaned or the bin emptied. After a thorough cleaning, I tried charging it and after about a half an hour, I received a charging error 5. All charging contacts are clean including the battery compartment contacts. I did a reboot by holding down the spot/dock buttons but still get the error. Is the battery ready to be replaced or is there something else I can try?

Thanks


Hi Jim, 6 years for a battery is good going. If the charger is still putting out power, it certainly sounds like a new battery is needed.

Sent from my iPad using Tapatalk
DeanR181
 
Posts: 17
Joined: December 12th, 2017, 10:58 pm

Re: 5 year old 650 not charging

Postby JiminSTLouis » January 1st, 2018, 1:01 am

DeanR181 wrote:
JiminSTLouis wrote:Hello

My daughter borrowed our 650 for a couple of years and I just took it back today. It looked liked it was never cleaned or the bin emptied. After a thorough cleaning, I tried charging it and after about a half an hour, I received a charging error 5. All charging contacts are clean including the battery compartment contacts. I did a reboot by holding down the spot/dock buttons but still get the error. Is the battery ready to be replaced or is there something else I can try?

Thanks


Hi Jim, 6 years for a battery is good going. If the charger is still putting out power, it certainly sounds like a new battery is needed.

Sent from my iPad using Tapatalk


I’m afraid you may be right Dean. I have the power cable plugged directly into the bot and get the pulsing amber charging light for about a half hour until the error. I’ve tried about 5 times tonight.

Thanks
JiminSTLouis
 
Posts: 13
Joined: December 27th, 2012, 1:56 pm

Re: 5 year old 650 not charging

Postby JiminSTLouis » January 1st, 2018, 11:17 am

I ordered a new (oem) battery from Amazon Prime. Hopfully the bot will be back up and running again in a couple of days.
JiminSTLouis
 
Posts: 13
Joined: December 27th, 2012, 1:56 pm

Re: 5 year old 650 not charging

Postby DeanR181 » January 1st, 2018, 4:32 pm

JiminSTLouis wrote:I ordered a new (oem) battery from Amazon Prime. Hopfully the bot will be back up and running again in a couple of days.
fingers crossed that it will resuscitate little bot.


Sent from my iPhone using Tapatalk
DeanR181
 
Posts: 17
Joined: December 12th, 2017, 10:58 pm

Re: 5 year old 650 not charging

Postby JiminSTLouis » January 5th, 2018, 5:56 pm

New battery is installed, charged and the bot is back to work!

Image
JiminSTLouis
 
Posts: 13
Joined: December 27th, 2012, 1:56 pm

Re: 5 year old 650 not charging

Postby DeanR181 » January 5th, 2018, 9:49 pm

Excellent, glad to hear it..


Sent from my iPhone using Tapatalk
DeanR181
 
Posts: 17
Joined: December 12th, 2017, 10:58 pm

Re: 5 year old 650 not charging

Postby JiminSTLouis » January 5th, 2018, 10:04 pm

DeanR181 wrote:Excellent, glad to hear it..


Sent from my iPhone using Tapatalk


It’s funny... it never used to go up onto my rugs now it plows right over the edge and vacuums all of them.
JiminSTLouis
 
Posts: 13
Joined: December 27th, 2012, 1:56 pm

Re: 5 year old 650 not charging

Postby GraceL » June 10th, 2018, 1:57 am

I have similar problem, but my iRobot does not showing any light and not responding. What should I do?
GraceL
 
Posts: 2
Joined: June 10th, 2018, 1:55 am

Re: 5 year old 650 not charging

Postby a1robotrepair » June 10th, 2018, 7:47 am

More info needed.
What does it do when placed on the base?
What does the base do when Roomba is placed on it?
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 945
Joined: October 14th, 2013, 8:40 am

Re: 5 year old 650 not charging

Postby GraceL » June 10th, 2018, 9:48 am

Google solution, reset the iRobot and use direct charge. Yet charging error 3 still showing. Tried multiple time to reset the iRobot, charging error 2 showing.
GraceL
 
Posts: 2
Joined: June 10th, 2018, 1:55 am

Re: 5 year old 650 not charging

Postby a1robotrepair » June 10th, 2018, 11:00 am

Charging error 2 and 3.
You can search this forum for multiple threads about CE3 & CE2.
Typically one must disassemble the robot, remove the circuit board and clean it.
The best way to clean it is with an ultrasonic circuit board tank, then dipping it in a tank of 99.9% IPA.
Another way is to use 99.9 IPA and a soft toothbrush, cleaning around U8 and its passive components.
If there is a lot of corrosion use a baking soda solution to remove deposits then clean very well with IPA.
This thread has good info on U8: http://www.robotreviews.com/chat/viewtopic.php?t=17151&p=139276#p139276
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 945
Joined: October 14th, 2013, 8:40 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Aniseedvan, Botty, Chonlameth, gregj, KeldBroe, kersian, Miles267, mobzd, someoneclever, vic7767 and 365 guests