Roomba 655 main brush working only in one way

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 655 main brush working only in one way

Postby hy_bsb » January 11th, 2018, 10:18 am

Hello to all. I'm new to this forum.
My 655 has the problem stated in the subject.
I suspect the problem could be in the H-Bridge, but I'm not sure where (or which one) it is in the mainboard.
I found good info on post "Roomba 560 not working brush" (http://www.robotreviews.com/chat/viewtopic.php?f=1&t=19065#p135595) but it is for 560 series and the layout of the main PCB is different (it says PCB R3 Rev. E - 2014, Jan 30).
I would appreciate if someone could point me to similar information for my model, or schematics or some kind of help.
Besides, I found corrosion on three solderings of other componets, but I don't know if they they are related to this problem.
In the picture linked bellow, I marked in red the corroded soldering and marked in green what for me is the most probable H-Bridge for main brush (in case you can confirm it).
https://drive.google.com/file/d/1dSN8O4snFD6QWjCgvUlYs2NUFaKb9NDG/view?usp=sharing
Thank you in advance for your help.
David
hy_bsb
 
Posts: 4
Joined: January 11th, 2018, 9:14 am

Re: Roomba 655 main brush working only in one way

Postby a1robotrepair » January 11th, 2018, 3:27 pm

While the components are a different size, their function and numbering is the same.
Use the URL you mentioned in your post to troubleshoot.
There is another URL in that thread that will take you to a list of URLs, one of which has a schematic of the right wheel H-Bridge. All H-Bridge circuits are wired the same, only the components numbers are different.
The newer R3 boards have 2 Schotkey Diodes, older have 4.
You are looking at the correct transistors.
Last edited by a1robotrepair on January 11th, 2018, 3:31 pm, edited 1 time in total.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 935
Joined: October 14th, 2013, 8:40 am

Re: Roomba 655 main brush working only in one way

Postby a1robotrepair » January 11th, 2018, 3:29 pm

Hi Guys,
Still in South America on my last commitment. Who knew there were so many Spanish language dialects?
Internet sucks here. Back soon.
Way off topic
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 935
Joined: October 14th, 2013, 8:40 am

Re: Roomba 655 main brush working only in one way

Postby hy_bsb » January 12th, 2018, 9:42 am

Thank you a1robotrepair for the info.
I live in Buenos Aires, Argentina, and agree that the internet sucks in most places.
I measured the H-Bridge and is but, in the other hand at least two of the suspicious soldering I mentioned for other components are damaged because of corrosion.
This is a picture:
https://drive.google.com/file/d/1HY8G0AXEP6BZwECQ8LnOg1MYk6bo3yBR/view?usp=sharing
One issue is that the terminal of transistor Q5 is damaged so it must be replaced. According to my research SMD coding 2X is equivalent to 2N4401.
The problem is that the PCB is also damaged, and because of the small size is not clear where it must be connected to.
Is there any chance of getting a schematic of this? Otherwise what would you suggest doing?.
Regards.
hy_bsb
 
Posts: 4
Joined: January 11th, 2018, 9:14 am

Re: Roomba 655 main brush working only in one way

Postby a1robotrepair » January 12th, 2018, 11:20 am

Q5 has no effect on the main brush circuit, CHM.
It, if memory serves me, supplies power or the bumper for its sensor arrays.
Check this post for YouTube bits under the R3 Heading: http://www.robotreviews.com/chat/viewtopic.php?f=4&t=19533
Check what else is not working.
You will probably have to trace that circuit yourself.
Montevideo is hit and miss with Internet also. I am told it's better the closer to the city you are.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 935
Joined: October 14th, 2013, 8:40 am

Re: Roomba 655 main brush working only in one way

Postby hy_bsb » January 12th, 2018, 6:05 pm

Thanks again, another question is what are the 6 pins in brush module connector (of course, apart from the two for the motor).
hy_bsb
 
Posts: 4
Joined: January 11th, 2018, 9:14 am

Re: Roomba 655 main brush working only in one way

Postby vic7767 » January 12th, 2018, 9:44 pm

POWER(2)), DIRT DETECT(4)
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14598
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Roomba 655 main brush working only in one way

Postby hy_bsb » January 19th, 2018, 3:11 pm

I'm back to report the results of my fixing job.
I replaced Q5 (2N4401) and R173 (61.9Ohm 1/4W), both having one of their pins missing because of corrosion (as seen in image linked in the original post).
Now the Robot works fine.
Before the repair it issued lots of "Error 2", "Error 5" and ""Error 6"" charging errors, and the main brush didn't move in forward direction.
Thanks a1robotrepair and vic7767 for your help.
Regards
hy_bsb
 
Posts: 4
Joined: January 11th, 2018, 9:14 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: johnnyh and 265 guests

cron