Roomba 980 always fails on carpet: no error, no pattern

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 980 always fails on carpet: no error, no pattern

Postby teaumaz » March 4th, 2018, 4:20 pm

I bought a Roomba 980 2 weeks ago. While it does a stellar job on our hardwood floors downstairs, I actually bought it for our fully carpeted 1st floor. However, the robot never manages to finish the job. It just stops, sometimes after 5 minutes, sometimes after 25 minutes. There is no error message or nothing. The app just says: Roomba is ready to clean. The only thing I’ve noticed is that the robot usually stops underneath or in the vicinity of our bed.

A few points:
- all rooms are well lit
- there are no obstructions underneath or in the vicinity of the bed
- even usin virtual wall or halo around bed does not prevent this behaviour
- our other robot, a Roomba 880, has never failed us on the carpet floor.

The firmware is 2.4.4-4

Any idea or anybody else experiencing this?

I’ve been in contact with iRobot customer support for the past two weeks back and forth but I get the feeling they don’t know what might be causing this either.
teaumaz
 
Posts: 1
Joined: March 4th, 2018, 4:08 pm

Re: Roomba 980 always fails on carpet: no error, no pattern

Postby BradfordRobbins » March 10th, 2018, 5:52 pm

I am having the same problem with a 980 running firmware 2.4.4-4
The roomba randomly shuts down with no errors and the app says it is still cleaning.
pushing the clean button restarts it.
pressing the home button does not send it to the docking station, it just keeps cleaning.
Suspected the battery contacts but now think there is a software bug.
I have contacted support but no response yet.
BradfordRobbins
 
Posts: 1
Joined: March 10th, 2018, 5:48 pm

Re: Roomba 980 always fails on carpet: no error, no pattern

Postby McStagger » March 19th, 2018, 10:36 am

I am having this issue as well. My version number is v2.2.10-1

When docked and told to clean, the Roomba undocks, moves a few feet and then just shuts down. If I redock and tell it to clean, it goes on its way and seems to function just fine and even goes as far as redocking to charge back up.

In other instances, it would start to clean and go about 15 or so minutes and then it would shut down.

I just sat through a chat session with an agent who is supposed to send me an email with some things to check. Once I get said email, I will update this comment with those suggestions.
McStagger
 
Posts: 5
Joined: March 19th, 2018, 10:33 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Brett, someoneclever, sondejmarek, symbol and 322 guests