Charging Error 5 - Roomba 770

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Charging Error 5 - Roomba 770

Postby shadowvfx » June 4th, 2018, 11:59 am

Hi everyone. I'm posting here because I'm fighting a two-front war here with my Roomba 770. I know there's other threads discussing ERROR 5, but most are years old and my issue seems a little different from the rest of those posts.

My trouble with this Roomba started about 2 months ago when it docked itself after cleaning the floor and I noticed it got the ERROR 5 while sitting on the dock. I moved it and re-seated the Roomba and it gave ERROR 5 again about an hour later. I was busy that night and just left the Roomba there until the next day I woke up and it was dead. Pressing the button on the top of the unit did nothing. I came to discover that the battery was completely drained. I put in a backup battery I have (the original battery it came with) and it also didn't work (perhaps it was totally drained too since it hadn't been used in over a year?).

The next thing I did was charge the Roomba directly with the power supply via the side port. This worked and the Roomba came back to life once the battery had fully charged. However, it now wouldn't dock with the docking station. After using Google I came across this forum and specifically this thread:

It was exactly the issue described. The "clean out the port" advice didn't help and the Roomba still wouldn't dock. So yesterday I disassembled the Roomba to get to the charge port wires and "shorted them out" as advised as an alternate option to this problem. Great, it worked. Now the docking issue is solved. The Roomba can now dock successfully.

Unfortunately, after about 1 hour on the dock, it threw out ERROR 5 again. It did this 2 or 3 times. I took my multimeter and tested the voltage of the power supply and it read ~22V and the contacts on the dock plates read ~2.8v. Someone in another thread said voltage didn't matter and that it was the current I need to be checking instead, so I guess I will do that when I get home.

However, I wanted to post my issue and process here to see if anyone has any suggestions for me? I bought a replacement dock and power supply when I was trying to resolve the docking issue thing, but those didn't solve my problem (probably because it was the side port interfering with the Roomba to dock/charge), so I returned those items. Now that the docking issue is resolved, I am wondering what might be causing the ERROR 5. I could try getting another replacement dock, but something tells me that is unlikely to be the faulty part. I am wondering if there's something actually wrong with the circuit board itself.

Anyways, that's all the information I can give you. If you have any advice for me on how to resolve ERROR 5, I'd love to hear it. Thanks for your assistance.
Posts: 10
Joined: April 25th, 2018, 2:08 pm

Re: Charging Error 5 - Roomba 770

Postby a1robotrepair » June 4th, 2018, 11:13 pm

I would suspect Q18 or Q17 as your problem.
Drawings in this thread,
Roses are red Violets are blue Poems are hard Flowers and Chocolate
Robot Master
Posts: 956
Joined: October 14th, 2013, 8:40 am

Re: Charging Error 5 - Roomba 770

Postby shadowvfx » June 7th, 2018, 8:58 pm

Wow, that's some complex stuff. Well, I think it may be time for me to donate this old 770. I'm bummed because it worked relatively well until this happened. I'm sure someone with more skill and time than myself could get this working quickly, but I don't think I can.

What do you guys do with your Roombas? Craigslist or Donate?
Posts: 10
Joined: April 25th, 2018, 2:08 pm

Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: KeldBroe, rob111gb and 323 guests