960 strange charging problem

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

960 strange charging problem

Postby flat5 » July 3rd, 2018, 12:20 pm

After about a year of daily use, my 960 seemed to be taking longer and longer to finish a job. So I replaced the battery with an aftermarket one off amazon. It seemed to work fine at first.

But now, something really strange is happening. The roomba shows that it is fully charged on the robot itself, with the green battery bar. But in the app, it shows it as almost totally discharged, red indicator that's empty or almost empty. It runs for about 5 minutes, then returns home to charge again.

Any ideas what's going on here? I've seen something about "resetting the charging system" but the instructions were contradictory and not for my model.
flat5
 
Posts: 29
Joined: January 1st, 2010, 1:42 pm

Re: 960 strange charging problem

Postby GSRtrent » July 3rd, 2018, 1:32 pm

The battery you bought off amazon; is that a Roomba replacement battery or a 3rd party battery? Always buy the manufacture replacement battery from their website. You may have gotten a knock off battery. Before it does damage, I would remove it and put the old one back in. See if the charging behavior changes. If it does then you know it was the new battery. Buy a new battery off their website. Don't try to go cheap on it either as it's a very important part.
GSRtrent
 
Posts: 4
Joined: June 28th, 2018, 9:59 am

Re: 960 strange charging problem

Postby a1robotrepair » July 3rd, 2018, 6:13 pm

GSRtrent wrote:The battery you bought off amazon; is that a Roomba replacement battery or a 3rd party battery? Always buy the manufacture replacement battery from their website. You may have gotten a knock off battery. Before it does damage, I would remove it and put the old one back in. See if the charging behavior changes. If it does then you know it was the new battery. Buy a new battery off their website. Don't try to go cheap on it either as it's a very important part.


I agree with GSRtrent!
There is only one known aftermarket battery which is good. LithiumPowerInc.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 945
Joined: October 14th, 2013, 8:40 am

Re: 960 strange charging problem

Postby flat5 » July 3rd, 2018, 11:16 pm

GSRtrent wrote:The battery you bought off amazon; is that a Roomba replacement battery or a 3rd party battery? Always buy the manufacture replacement battery from their website. You may have gotten a knock off battery. Before it does damage, I would remove it and put the old one back in. See if the charging behavior changes. If it does then you know it was the new battery. Buy a new battery off their website. Don't try to go cheap on it either as it's a very important part.


It is a 3rd party battery. But, I don't know of any reason why a 3rd party battery couldn't be just as good as the OEM.

It's this battery here:
https://www.amazon.com/gp/product/B00SW ... merReviews

which seems to have a pretty good track record.

Rebooting the robot by holding down the clean button for 10 seconds seems to have fixed the discrepancy between the green light on the robot and the red light in the app. Both show it fully charged now. Let's see how it runs...
flat5
 
Posts: 29
Joined: January 1st, 2010, 1:42 pm

Re: 960 strange charging problem

Postby flat5 » July 5th, 2018, 12:32 pm

It seems to be operating normally after resetting the robot by holding down clean for 10 seconds.
flat5
 
Posts: 29
Joined: January 1st, 2010, 1:42 pm


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: BCCISProf, ccp, Miles267, orion262, ps0001, RRandal58 and 329 guests