Roomba 590 all brushes stopped

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 590 all brushes stopped

Postby Phiggystardust » July 29th, 2018, 6:11 am

Can anyone help all was fine now all brushes have stopped all is clean on both main and side brushes inside gearbox too ! Any thoughts most welcome
Phiggystardust
 
Posts: 2
Joined: July 29th, 2018, 6:08 am

Re: Roomba 590 all brushes stopped

Postby a1robotrepair » July 29th, 2018, 1:07 pm

More than likely the Cleaning Head Module motor is bad or full of dust and dirt.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 949
Joined: October 14th, 2013, 8:40 am

Re: Roomba 590 all brushes stopped

Postby Phiggystardust » August 7th, 2018, 4:14 pm

thanks for your reply
strange that both the main and side brushes have stopped , no errors either
Phiggystardust
 
Posts: 2
Joined: July 29th, 2018, 6:08 am

Re: Roomba 590 all brushes stopped

Postby vic7767 » August 8th, 2018, 11:57 am

Go here: http://choisirsonaspirateur.info/wp-con ... Manual.pdf
and download the Service Manual. Read through the manual and see how to run the MANUAL BiTs mode. This may help you determine the cause of motor failure. If you can monitor the SCI channel during the tests much info about the health of the brush deck motor and side brush current consumption may be discovered.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14779
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Atena, bruce9241, Fred_75, johnnyh, KeldBroe, mobzd, ntxmac, someoneclever, vinhvu and 344 guests