SOLVED: Roomba 500 One very Peculiar not easy Problem

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

SOLVED: Roomba 500 One very Peculiar not easy Problem

Postby Armadillo2 » August 27th, 2018, 3:38 am

This roomba has a very peculiar problem not found in all the WWW, I searched.

If I press the Clean button once;

When the Clean LED turn On Green with a Sound, the roomba can operate normally.

but for most of the time;

The LED turn Green like normal without the Sound and the roomba will refuse to move [press Clean button again] or turn itself off except Reset. There are no error tone, sound or blinking. Its like dead except the Reset which reset the ucontroller.

I swoop the MB to another machine and it still repeat the same problem so the MB is the problem, confirmed.
I am thinking that the ucontroller is waiting for something? during the startup and I don't know what's happening.

Anyone has a great idea where to begin?

Thanks to all.
Last edited by Armadillo2 on August 30th, 2018, 10:32 am, edited 1 time in total.
Armadillo2
 
Posts: 4
Joined: August 27th, 2018, 3:20 am

Re: Roomba 500 One very Peculiar not easy Problem

Postby a1robotrepair » August 27th, 2018, 6:19 pm

Try cleaning the circuit board battery connectors with alcohol & rag.
Then bend them down a little.
Next would be check D46 and Q18.
Roses are red Violets are blue Poems are hard Flowers and Chocolate
http://www.daycounter.com/Calculators/
a1robotrepair
Robot Master
 
Posts: 949
Joined: October 14th, 2013, 8:40 am

Re: Roomba 500 One very Peculiar not easy Problem

Postby Armadillo2 » August 28th, 2018, 6:33 am

Thanks, at least there is a reply to this complex problem.....

@a1robotrepair

Hi Robot Master, thanks for reply. I have checked D46 and Q18, both are OK.
There are no problems during charging and the 5VReg buck is OK.

When it's operate normally, the robot can clean for over over 30 minutes, no problems, the connectors are cleaned.

What about U20? I remember I did swoop with a "PASI" before. Maybe I should go thru my microscope on that joints as well, when I got the time. Was a quick lazy job at it before. But I doubt it considering I can press the Clean button.

Do let me know your thoughts. Thanks for sharing.
Armadillo2
 
Posts: 4
Joined: August 27th, 2018, 3:20 am

Re: Roomba 500 One very Peculiar not easy Problem

Postby Armadillo2 » August 30th, 2018, 10:32 am

Thanks guys, the problem has been resolved.

Cause: Improper Reset Sequence and timing.
Armadillo2
 
Posts: 4
Joined: August 27th, 2018, 3:20 am

Re: SOLVED: Roomba 500 One very Peculiar not easy Problem

Postby leonicholson » August 30th, 2018, 11:26 am

How do you reset a 500 series (595)?
leonicholson
Robot Addict
 
Posts: 131
Joined: November 3rd, 2017, 5:25 pm

Re: SOLVED: Roomba 500 One very Peculiar not easy Problem

Postby Armadillo2 » August 30th, 2018, 1:39 pm

leonicholson wrote:How do you reset a 500 series (595)?


For User application level, pressing down the Roomba’s SPOT and DOCK simultaneously for 10 seconds.
Armadillo2
 
Posts: 4
Joined: August 27th, 2018, 3:20 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: Agfadoc, BCCISProf, im1kissfan, jdong, sshephard, vic7767 and 398 guests