IRobot 980 docking problems

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

IRobot 980 docking problems

Postby chichigirl46 » September 25th, 2018, 11:23 pm

I have had my robot replaced 5 times due to not being able to dock & path not blocked, dying in the middle of the floor after running about 5min’s to 35 min’s, these have been major problems after first purchase running great for about 6 months until an app update. Now my robot being replaced 5 times all with the same problems until this last August app update my robot could dock and clean the whole house, thought my problem has finally been fixed, todays app update caused the robot not being able to dock again. This is so aggravating because IRobot customer service will not except that it is their app updates causing these problems and telling me it is environment problem in my home, well then why did my first purchase ran 6 months great until their app’s updates. Anyone else having this problem or have a solution to this docking problem?
User avatar
chichigirl46
 
Posts: 1
Joined: September 25th, 2018, 10:39 pm

Re: IRobot 980 docking problems

Postby RTC » September 26th, 2018, 7:57 am

chichigirl46 wrote:Anyone else having this problem or have a solution to this docking problem?


You don't by any chance have the Home Base plugged into a UPS or other type of "power converter"?
I started getting random intermittent failures to return home when I moved my 980 into another room and inadvertently plugged into the UPS that was in the room. Customer service repeatedly denied that there could be any problem running on a UPS. However I eventually found the warning (in the Battery section) not to plug into any type of "power converter". Plugged directly into the wall or a surge suppressor the 980 works perfectly.

P.S. I cannot run the app as I don't have a smartphone.
RTC
Robot Groupie
 
Posts: 86
Joined: August 23rd, 2018, 7:23 pm

Re: IRobot 980 docking problems

Postby jikel » February 18th, 2019, 4:23 pm

This has been ongoing with my unit for about 4 months now. It worked great for 12 months but now it runs out of power and does not get a recharge about 1 in 5 runs. iRobot help is in denial on each call and blames base location etc. even though that worked fine for a long time. Never thought about updates, but that sounds like a good candidate for the problem source. Sometimes it runs out of power in mid job in a random room, others it is obviously making its way back to base but just never makes it. I asked if they could adjust the margin of power remaining so as it has more reserves to make it home, but was told no. Seems like a good option for them to include in the next update. Latest fix offered is that I buy a second base and segregate the house but that seems to defeat the purpose of buying a unit with the recharge/resume feature.
jikel
 
Posts: 1
Joined: November 22nd, 2017, 1:33 pm

Re: IRobot 980 docking problems

Postby vic7767 » February 18th, 2019, 6:57 pm

Your 980 may be suffering from a bad cell in the Lithium pack that causes loss of reserve capacity faster than normal.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14881
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: ASTMedic, im1kissfan, inetjnky, vic7767 and 378 guests