Page 1 of 1

Roomba 4210 charging issue

PostPosted: October 5th, 2018, 1:05 pm
by sandyjohn522
First of all, I'm a 70 year old woman. I've bought (4) 4210 Roombas and a couple in the 500 series in the last couple of months. I buy them not working, and I fix them. I've replaced the entire sensor section on one, and a motor wheel on another one. The rest just needed cleaning, and new batteries. BUT NOW I'M STUMPED! I have one that won't charge the battery. As a matter of fact, I think it ruined a brand new battery by discharging it to where it can't be recharged. I"ve tried using different docks, and fast charges. I can charge a battery in another Roomba, then put it in this broken one, and it cleans like a champ. Just won't charge a battery. I've been reading some old posts, and it looks like my problem is the U2 and U4 Mosfets. Would these parts cause a battery to be completely discharged to the point of ruining a good battery? I've tried to understand the directions to get to the point that I can see these u2/u4 parts, but I guess it's just over my head. The only circuit boards I see is one that stands on it's end, blocked in to where I can't get to it. What am I missing? I don't see where anyone has mentioned that these bad parts will cause the complete depletion of a battery. I probably have a worse problem, but would like to hear opinions from others.

Re: Roomba 4210 charging issue

PostPosted: October 5th, 2018, 5:51 pm
by vic7767
The U2 & U4 charging MOSFETs when damaged can cause not only a false charging condition but can also discharge the battery so low that another Roomba cannot charge the pack and may also be subjected to damaged charging MOSFETs as well. The rule seems to be that if the pack being charged is below 10 vdc then don't attempt to charge it using your R2 Roomba. Instead use a stand alone battery charger.

The MOSFETs are located on opposite sides of the circuit board you describe in your post that is mounted in a vertical position. It requires the removal of all the wire connectors plugged into the circuit board as well as the two black plastic retainers located at each end of the circuit board that hold the two springs for the drive wheels. These MOSFETs are very small SMDs, (surface mount devices) that require some soldering skills to remove and replace.

Re: Roomba 4210 charging issue

PostPosted: October 8th, 2018, 10:00 am
by sandyjohn522
Thank you, Vic! I think that's way over my head. I did take the little plugged wires off around where my battery connection is. I marked each one with a different colored marker, so I'd get them back right. Coloring each connection, and each connector with the same color marker. I took the contacts out for the battery and cleaned them, too. I should have known that wasn't the problem, since I don't think bad contacts would cause the discharging. I think this Roomba is toast, so I wouldn't be afraid of making it worse by trying to take it apart, but I read in another area here that getting it too hot when soldering fries it. I couldn't do this, and my husband would fry it! Plus, I tried to look at a diagram for where these MOSFETS are located, and I didn't see them. Unless it was really blown up, and the exact parts were circled.....I'd never make it out. Heck, I don't have a clue what a MOSFET looks like, or where to get them. I'm not even sure how hard it is to get that motherboard out. I picture it fitting like a memory stick does in a computer, just wiggle it out and click it back in? But, thank you again for your help. Sorry it took me so long to come back to look for a reply. I was expecting an email to tell me I had a reply, and of course that isn't the case. I love these forums! You can learn how to do just about anything, and you guys make us look so intelligent to our friends!