Roomba 770 Red Triangle no beeps

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 770 Red Triangle no beeps

Postby sandyjohn522 » October 15th, 2018, 11:21 am

I called Roomba, and they told me when the roomba flashes the red triangle with no error blinks, or spoken error messages that it's the dust bin. It is inserted perfectly, but I found this problem. Please see the pictures. It looks like there is supposed to be a post between the dust bin contacts, and I don't have one. I took the trim piece off on the top, and it looks like a post has been broken off. There is a hole where maybe a piece would fit down in it, and would possible make it more stable or a tighter fit. I'm not explaining this very well, but I hope the pictures will tell the story for me. I bought this at an auction, so I don't have any history on it. Anybody have any suggestions? Thanks!
Attachments
roomba 770 2.JPG
roomba 770 2.JPG (40.84 KiB) Viewed 553 times
Roomba 770.JPG
Roomba 770.JPG (29.37 KiB) Viewed 553 times
sandyjohn522
 
Posts: 5
Joined: October 5th, 2018, 12:50 pm

Re: Roomba 770 Red Triangle no beeps

Postby sandyjohn522 » October 15th, 2018, 11:28 am

One more important observation. When I push clean, it just makes a nano-second attempt to move, and then stops and flashes the triangle. If it's on the dock, it will back up, turn around and then make that nano-second attempt to move. I would think it could be the sensors on the front, but Roomba says it would give me an error message if it was another problem. The motherboard could be toast for all I know. I paid $85 for it, which isn't a fortune, but it's more than I want to throw away.
sandyjohn522
 
Posts: 5
Joined: October 5th, 2018, 12:50 pm

Re: Roomba 770 Red Triangle no beeps

Postby Brett » October 15th, 2018, 10:14 pm

There is no "post" there aside from the ring that clicks through the plastic to hold that trim in place. It has no bearing on the function of the dust bin.

Try the BiTs and that should tell you more of what is happening...
Time flies like an arrow.
Fruit flies like a banana!
User avatar
Brett
Robot Addict
 
Posts: 379
Joined: November 2nd, 2009, 8:50 pm
Location: Perth, Western Australia

Re: Roomba 770 Red Triangle no beeps

Postby sandyjohn522 » October 15th, 2018, 10:45 pm

Thank you so much for telling me that. It's been driving me crazy. I can't find step by step directions on how to do the tests. I got it in the mode to test, but then I didn't know what to do. I pushed the bumpers in, and it responded. I didn't get a voice response, just some beeps. I kept pushing the spot button and I did see the wheels go around. First forward, and then backwards. I never saw it test the wheels individually. I also saw the side brush go around, and I think I saw the cleaning brushes work...but I never heard the dust bin come on. I just kept punching the spot button, but I didn't know what I was supposed to do after that point. My husband took the dust bin out and connected it to a portable charger, and it ran. Is there a list of what I'm supposed to do in the test mode? I know the lights come on, but I'm not even sure what I'm supposed to do to move to the next test. I just pushed "spot". After that...I just kept pushing spot till I didn't see it doing anything else. Thanks for any help!
sandyjohn522
 
Posts: 5
Joined: October 5th, 2018, 12:50 pm


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: im1kissfan, jdong, leonicholson, Miles267, NoJimForHome, sshephard, TechGuy, vic7767 and 362 guests