Scooba 230 Red Light & Beeps?

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Scooba 230 Red Light & Beeps?

Postby Botty » October 16th, 2018, 4:29 pm

So i just bought this scooba 230. brand new, still in wrapping, never used etc...
charged the battery for nearly 24 hours and went to use it this evening.

Pressed the 'clean' button, scooba whirrs for about 30 seconds then the red light comes on and two beeps. Manual says that the red light indicates low battery

trimmed video to save you ages of whirring: https://youtu.be/fq-meNuhfas

Since the 230 is an old unit and this one has never been used i thought maybe the battery has just eroded over the years from non-use, so I've put another battery in (a new one bought last week) and left it on charge to try again tomorrow. But while I'm waiting, have any of you seen this before? Googled the symptoms and there's not much out there except people saying to put some salt in the water.
Botty
Robot Groupie
 
Posts: 92
Joined: August 27th, 2018, 9:53 am

Re: Scooba 230 Red Light & Beeps?

Postby Botty » October 19th, 2018, 9:50 am

fwiw I managed to solve this, but not sure how. Took the battery out and put it back in, powered it on, pressed and held the clean button for about 20 secs, took the battery out & in again, powered up and pressed clean and off it went. Working perfectly now. No idea which of those steps fixed it.
Botty
Robot Groupie
 
Posts: 92
Joined: August 27th, 2018, 9:53 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: im1kissfan, leonicholson, Miles267, NoJimForHome, sshephard, TechGuy, vic7767 and 368 guests

cron