Braava Jet dead but battery charged

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Braava Jet dead but battery charged

Postby piokrza » November 8th, 2018, 5:49 pm

I got used Braava 240 recently in excellent condition. When I want to put battery in wall charger it rapidly pulses amber then switches green. But when I put it inside Braava body and press Clean button it won't wake up.
piokrza
Robot Master
 
Posts: 3470
Joined: May 18th, 2009, 8:17 am
Location: Poland

Re: Braava Jet dead but battery charged

Postby vic7767 » November 8th, 2018, 6:14 pm

What is the voltage in the battery? Try performing a load test.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14895
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Braava Jet dead but battery charged

Postby piokrza » November 11th, 2018, 9:26 am

Thanks for reply vic. I've purchased new battery and it works fine both robot, wall charger and battery. So this was fault on the side of old genuine battery that comes with this used machine to me. Now, any idea how to check its manufacture date (battery, robot) ?
piokrza
Robot Master
 
Posts: 3470
Joined: May 18th, 2009, 8:17 am
Location: Poland

Re: Braava Jet dead but battery charged

Postby jmiranda7777 » January 21st, 2019, 10:48 am

I have a few Braavas' and I have a problem with the battery it seems like the contacts don't line up when I plug in the battery. Something is wearing out over extended use.

If I plug in the battery while holding down the power button I can usually wiggle it in and out until works. I can see where the robot turns on and position the battery so it works. It just takes time.

Sometimes I can add tape to space the battery so they line up.

The contacts are pretty delicate I have tried scraping them and that sometimes work but more often that not it damages the batteries

I have at over 10 batteries and this seems to happens to the older batteries I have checked lipo voltage and the batteries are well withing acceptable voltage. Its an issue with the contacts.

Anyone else having issues or have solutions I have at least 4 dead batteries and its not the battery it the connector.

I am contemplating opening up a robot and wiring an 18650 battery holder outside the robot.

Anyone have other solutions.
jmiranda7777
 
Posts: 1
Joined: January 21st, 2019, 10:30 am


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: ASTMedic, BCCISProf, Metalworker and 342 guests

cron