Switch to full style
The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.
Post a reply

980 Extractor Noise

February 28th, 2019, 3:36 pm

Recently bought a Craigslist 980 that works perfectly, connects to WiFi, etc.
Problem is with the extractors. I tried an aftermarket set and an OEM iRobot set.
Both make loud noise and, upon inspection, appear to contact each other - unlike the worn ones (which do not have this problem).
I can replace the one nearest the bin with no noise if I leave the other old one installed. This is the same result with either the aftermarket or iRobot set.
I have same behavior with my 805.
For now, I'm just using one new one with one old one, but is there a solution for this?

Re: 980 Extractor Noise

February 28th, 2019, 4:49 pm

The extractor brushes are designed to be close together. The vacuum suction is increased when there is a smaller opening between the two brushes. You may just need to install both new brushes and let them work in over a few cleaning cycles.

Re: 980 Extractor Noise

February 28th, 2019, 5:28 pm

Thanks

Will try swappimg my quiet 805 extractors with the 980's and try to "wear in" the new extractors in the 805.

I have concerns that something could get damaged, but maybe they'll wear in quickly in the 805 while not risking the 980.

I wonder if this is a common problem with new extractors.

Re: 980 Extractor Noise

March 1st, 2019, 5:46 am

leonicholson wrote:I wonder if this is a common problem with new extractors.


I have replaced the extractors on my 980 once and there was no noise.
The wear on the original ones was insignificant and I may put them back in at some point.
Post a reply