Roomba 980 New Extractor Module Not Working

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Roomba 980 New Extractor Module Not Working

Postby dfaherty » May 1st, 2019, 1:35 pm

Hello. I installed a new extractor module because the old one was not spinning. After installing the new one it appears this one doesnt want to work as well. Everything else works fine. Any ideas?
dfaherty
 
Posts: 3
Joined: May 1st, 2019, 1:31 pm

Re: Roomba 980 New Extractor Module Not Working

Postby vic7767 » May 1st, 2019, 1:51 pm

Perform the built in tests to determine if the H-bridge is defective.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14917
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Roomba 980 New Extractor Module Not Working

Postby dfaherty » May 1st, 2019, 2:17 pm

Didnt know there was such a thing. How do you perform that test?
dfaherty
 
Posts: 3
Joined: May 1st, 2019, 1:31 pm

Re: Roomba 980 New Extractor Module Not Working

Postby dfaherty » May 1st, 2019, 2:43 pm

I figured it out and it appears the extractors will not turn
dfaherty
 
Posts: 3
Joined: May 1st, 2019, 1:31 pm

Re: Roomba 980 New Extractor Module Not Working

Postby vic7767 » May 1st, 2019, 2:49 pm

If the brush deck motor does not spin the extractors in either direction then your main board H-bridge is defective. It will require a circuit board replacement.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14917
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: BrettS, im1kissfan, Ionic, jdong, johnnyh, vic7767 and 353 guests