Neato NOT charging anymore!!

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Neato NOT charging anymore!!

Postby warlock79 » September 25th, 2011, 4:23 am

Good Day,

I have a strange problem since yesterday. As my batteries drained out completely after 6 months of use, I replaced them with a set of new batteries. Things were working fine for a week. Since yesterday it is not charging anymore. If the Neato is made contact with the charging base, all i see is a flickering orange/red light around the start button. If I press start, the device is kinda dead (means no power at all.) I removed the batteries and cleaned the contact pins, waited 5 mins before connecting. But no luck. Btw.. I use the latest FW 2.1 and its a XV-11.

Anybody experiencing the same problem? As I live in Switzerland, I am really not sure whether its worth shipping it back to US for a replacement. Please do share your thoughts if any workaround is possible.

Kind regards,

Sam
warlock79
 
Posts: 42
Joined: July 27th, 2010, 8:37 am

Re: Neato NOT charging anymore!!

Postby rampar » September 25th, 2011, 4:50 am

try charging directly with the plug, if you take apart the dock you will find the plug.
rampar
 
Posts: 22
Joined: July 10th, 2011, 1:43 am

Re: Neato NOT charging anymore!!

Postby Blind Guy » September 25th, 2011, 1:53 pm

rampar is correct, open your base and remove the plug inside, plug that plug directly into Neato, charge Neato until its Light is green. If Neato's Battery charges and Neato works OK, reassemble the base with the charger, making sure the plug you plugged into Neato is plugged FIRMLY into its connectior inside the base.

That could possibly have been your problem.

David (aka Blind Guy)
Blind Guy
Robot Addict
 
Posts: 165
Joined: June 3rd, 2011, 3:10 pm
Location: Springfield, Mo.

Re: Neato NOT charging anymore!!

Postby sotm » September 25th, 2011, 4:47 pm

Hi warlock79:

warlock79 wrote:Good Day,

I have a strange problem since yesterday. As my batteries drained out completely after 6 months of use, I replaced them with a set of new batteries. Things were working fine for a week. Since yesterday it is not charging anymore. If the Neato is made contact with the charging base, all i see is a flickering orange/red light around the start button. If I press start, the device is kinda dead (means no power at all.) I removed the batteries and cleaned the contact pins, waited 5 mins before connecting. But no luck. Btw.. I use the latest FW 2.1 and its a XV-11.


I think 6 months is too short for new batteries. Maybe the exchanged batteries are not wrong if you are experiencing problems now with the new ones.

Anyway, just in case, have you used the option "new battery" inside the support menu? It could be more important than what we thought. If you have already worked well with the batteries for a week could not be the reason. Not sure.

Best regards,
-=<Sinner of The Meadows>=-
sotm
 
Posts: 18
Joined: September 15th, 2011, 3:14 am

Re: Neato NOT charging anymore!!

Postby warlock79 » September 25th, 2011, 11:24 pm

Hallo folks,

I did connect the charger directly to Neato and it now gets to charge. When I changed the new batteries last week, I did choose "new battery" inside the support menu as well. Anyway now it works.

Thank you
warlock79
 
Posts: 42
Joined: July 27th, 2010, 8:37 am

Re: Neato NOT charging anymore!!

Postby KareBehr » December 21st, 2016, 11:25 pm

I have the same 'not charging' issue...would like to try charging my bot directly as suggested but do not understand the location of the plug receptacle on the actual Bot...I am running Neato Connected model, and it is less than 6 months old.
KareBehr
 
Posts: 2
Joined: December 21st, 2016, 11:23 pm

Re: Neato NOT charging anymore!!

Postby KareBehr » December 21st, 2016, 11:45 pm

Well...I got a NEATO tech to troubleshoot...my problem was solved with a simple 'reset'...
open the dust bin and turn the BOT off...then park it in the docking station with the contacts touching.
The display indicated it was charging. Then I was instructed to open the dust bin and turn the unit back on. This completed the reset and my unit operated normally. I have a NEATO Connected. I love the product, and my experience with Customer Support has been outstanding.
KareBehr
 
Posts: 2
Joined: December 21st, 2016, 11:23 pm

Re: Neato NOT charging anymore!!

Postby Nerox » March 23rd, 2017, 8:13 am

Great ! Worked on a Botvac 85 Bought off ebay ! Now it's charging :D !!!!!

THANKS KareBehr

EDIT : Only cahrged for 5 minutes -_-
Nerox
 
Posts: 2
Joined: March 23rd, 2017, 8:03 am

Re: Neato NOT charging anymore!!

Postby ermacian » July 10th, 2018, 1:25 am

Just go to your options on your Neato vacuum, go to options and press new battery. It should work after that.
ermacian
 
Posts: 1
Joined: July 10th, 2018, 1:24 am


Return to Neato Robotics

Who is online

Users browsing this forum: BCCISProf, someoneclever, teokakav and 295 guests