Anyone else having trouble upgrading to 3.1?

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 17th, 2013, 7:30 pm

Although I tried many times, I don't seem to be able to upgrade my Neato robot to software version 3.1. Here are the details:
  • Neato vacuum specs: SN 0048178, SW 2.6.15840, LDS V2.6.15295, Board Rev 113.
  • Using Windows 7 SP1 (64-bit) on Dual Core AMD 7750 (2.70 Ghz).
  • Using high speed (cable) ADSL.
  • Neato Updater Tool installs with no problems.
  • Have tried using both FireFox 18.0 and IE 9.x. Popups are disabled, but no prompts about suppressed popup windows are displayed. Both browsers prompt to run the download file using the Neato Updater Tool (as expected).
  • Have tried with hardware firewall disabled (DMZ) and added rule to Windows Firewall to allow Neato Updater Tool unrestricted Internet access.
  • Each time I try to update, I get the following error message: "Error Installing Update. The Neato Updater Tool installed on your computer is unable to receive any data back from your Robot."

Suggestions?
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby a4refillpad » February 17th, 2013, 7:39 pm

Have you tried using a powered USB hub and other suggestions on the thread? Have you tried creating a terminal session to see if you get a connection and prove drivers installed properly? Also am aware of a number of people complaining that AMD chipsets not working properly so it is possible you may need to resort to using another machine.
current bots: Clebo Arte, Vorwerk VR-100 (one broken one new), Neato XV-25, Neato XV-12, Roomba 564, Evo Mint 2, Roomba 770, Hauzen VC-RE70V, Samsung SR8980, Karcher RC3000, Robomow RL350 (lawnmower)
previous bots: Samsung SR8845, Neato XV-15
User avatar
a4refillpad
Robot Addict
 
Posts: 400
Joined: March 23rd, 2012, 7:49 pm
Location: UK

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 17th, 2013, 11:32 pm

Yup, no luck with a powered hub. As for a terminal session - what IP, which port?
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 17th, 2013, 11:36 pm

Okay, I answered my own question - I'll give it a try:
http://www.neatorobotics.com/programmers-manual/
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby glnc222 » February 18th, 2013, 1:51 am

certain AMD Machines Incompatible -- Driver Defect
and do not communicate with Neato -- just as it says in the error msg. The older updating app did not give a separate msg for this, so you had to test with a terminal session -- no longer.

Hopefully this banner will make it easier for readers to catch this amid all the text.
System bd drivers for AMD machines will not be fixed because only Neato's unusual protocol encounters an issue.
glnc222
Robot Master
 
Posts: 1848
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 18th, 2013, 5:21 pm

Unfortunately, the terminal session (to COM8) failed. I've contacted Neato Support. I expect that I'll get a message saying: "We're sorry, your computer is not compatible with our software." rather than "We're sorry, our software is not compatible with a generic PC such as yours.". Grrrr ...
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 18th, 2013, 5:22 pm

glnc222 wrote:AMD Machines Incompatible -- Driver Defect


Thanks for the info ...
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby a4refillpad » February 18th, 2013, 8:24 pm

you have access to another pc or mac to try?
current bots: Clebo Arte, Vorwerk VR-100 (one broken one new), Neato XV-25, Neato XV-12, Roomba 564, Evo Mint 2, Roomba 770, Hauzen VC-RE70V, Samsung SR8980, Karcher RC3000, Robomow RL350 (lawnmower)
previous bots: Samsung SR8845, Neato XV-15
User avatar
a4refillpad
Robot Addict
 
Posts: 400
Joined: March 23rd, 2012, 7:49 pm
Location: UK

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 18th, 2013, 8:33 pm

I have immediate access to more than 6 PC's - all with AMD chipsets! I'll have to borrow an Intel laptop ... Thanks!
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby davidelewis » February 22nd, 2013, 8:18 pm

I finally got around to borrowing a PC laptop with a Celeron Core 2 Duo (Intel-based CPU) ... the upgrade then went smoothly! Producing a driver that is is not compatible with 17% of PC's (AMD's market share) seems ridiculous!
Neato XV-11 with 3.1 firmware
Roomba 580 with wireless remote
Scooba 5800 with PWR+ battery
Roomba Scheduler 4230 (passed along to a friend)
User avatar
davidelewis
Robot Addict
 
Posts: 173
Joined: March 30th, 2007, 11:53 am
Location: British Columbia, Canada

Re: Anyone else having trouble upgrading to 3.1?

Postby toronto-neato » May 11th, 2013, 11:54 pm

Just upgraded to 3.1 (from version 1.x). Important notes:

Used an Intel PC (I've read there may be problems with AMD chipsets and USB ports, but I couldn't test that) with Windows 8 (using this trick to get Neato Updater 2.0 to install properly: http://capirgotech.wordpress.com/2013/0 ... windows-8/ )

Had to *disconnect* my router and use a direct Ethernet connection to the computer from the cable modem.

I used Firefox.

It went flawlessly, and quickly (just a couple of minutes) when nothing else worked. I spent probably four hours on this to get this going. Please, Neato: add these tips to your updater website at least, to minimize the grief of your proud Neato owners? We're a tech-savvy bunch here, but most consumers really aren't.

Glad to add my 2 cents' worth on this very vexing problem...
toronto-neato
 
Posts: 3
Joined: September 1st, 2011, 11:51 pm

Previous

Return to Neato Robotics

Who is online

Users browsing this forum: Fraggboy, Gordon, mfortuna, peswe, vic7767 and 212 guests