My vision was blocked. Please press OKAY (3000)

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Re: My vision was blocked. Please press OKAY (3000)

Postby DarkLeftArm » March 13th, 2017, 8:07 pm

Thanks for this, but all that was done ad infinitum before I ever found this forum. My Lidar tower is now totally disassembled waiting for new parts. The motor was shot, so I have a new Jameco unit. The slip ring that supplies the signals and power to the laser itself was totally fried. It felt like a ratchet, so I have ordered a new unit from the factory in Hong Kong that made them. Since Neato won't carry them, I went to the source. I was surprised nobody here seemed to have ever messed with one of these.
Succeed or fail, I will post my results here. This forum seems like a pretty good record of things people have done to these things.

Cheers
Bert
DarkLeftArm
 
Posts: 4
Joined: March 7th, 2017, 1:40 pm

Re: My vision was blocked. Please press OKAY (3000)

Postby glnc222 » March 13th, 2017, 8:48 pm

If possible please post part identification and source for the slip ring, not seen before.
glnc222
Robot Master
 
Posts: 4064
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: My vision was blocked. Please press OKAY (3000)

Postby Tritonal » March 20th, 2017, 10:34 am

As many other people here I am getting the vision blocked error. This started a good while ago but I'm just getting around to doing something about it. The turret won't spin any more so I was guessing motor. Downloaded a neato control program ran through the motions testing everything I could and all seems to work minus motor. I had already ordered a new motor so I tore it apart replaced the motor cleaned it and put it back together. I've read that the polarities are reversed so I made sure I plugged the motor in the way it was before. After getting it put back together and started up the turret now spins but its not a steady spin it's kinda pulses a few times before the neato pops up the vision blocked error. Maybe I didn't connect the positive and negative right? I ran the program again fired up the turret motor from the program and same thing, it spins but isn't really constant more of a pulse. Few seconds on then slows then few seconds on then slows. I also tried using the scan tool but it wouldn't output anything.

So all in all I'm thinking either 1. I hooked the power up wrong or 2. the lidar itself is bad. Any insight before I start tearing into it again?
Tritonal
 
Posts: 4
Joined: March 20th, 2017, 10:25 am

Re: My vision was blocked. Please press OKAY (3000)

Postby vic7767 » March 20th, 2017, 1:38 pm

Step 1) Reverse the polarity of your dc motor. Make sure when the motor is spinning that it is spinning counter clockwise when viewing the pulley mounted on the shaft.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14141
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: My vision was blocked. Please press OKAY (3000)

Postby Tritonal » March 20th, 2017, 2:56 pm

So I checked it to see which direction it was spinning and it's counter clockwise and it's actually cleaning now!

I don't know why it is now but wouldn't this morning but I'm not looking a gift horse in the mouth. Now I have a whole seperate issue. I had 4 plastic pieces left over that I could figure out where they went to save my life. So I decided to put it all together and find out that way. Well apparently they are for the bumpers. lol. Oh well its cleaning now, though not having an easy time of it. When its all done I'll take it apart put the plastic pieces on and hope it still works.

So I'm now certain the polarity was right atleast
Tritonal
 
Posts: 4
Joined: March 20th, 2017, 10:25 am

Re: My vision was blocked. Please press OKAY (3000)

Postby glnc222 » March 20th, 2017, 3:37 pm

When installing the four bumper actuators with pins into sockets in both the top and bottom of the case, check the bumper action holding the case closed, before fastening the numerous screws, as the case can be closed with an actuator jammed out of position.
glnc222
Robot Master
 
Posts: 4064
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: My vision was blocked. Please press OKAY (3000)

Postby Tritonal » March 20th, 2017, 6:49 pm

Got it all put back together with the bumpers installed. All worked great. Did a cleaning of a room then displayed the vision blocked 3000 error again. Turret rotates but looking in I don't see the faint red of the LIDAR. Thinking the lidar is bad.
Tritonal
 
Posts: 4
Joined: March 20th, 2017, 10:25 am

Re: My vision was blocked. Please press OKAY (3000)

Postby Wing Nut » March 20th, 2017, 9:38 pm

Tritonal wrote:but looking in I don't see the faint red of the LIDAR. Thinking the lidar is bad.

I'm not sure you can with just your eyes? I know with the XV series the IR Lidar's laser is only seen when viewed through a common type of video camera, the ones typically found in cellphones.
#1 Neato XV-11 SW 2.0 Board Rev 113 / 3500mAh battery pack installed May 2013 / Pet & Allergy pack installed Sept 2013. In July 2014, received and repaired a faulty #2 Neato XV-11, running Lithium Power 4400mAh battery since July 2015
User avatar
Wing Nut
Robot Addict
 
Posts: 341
Joined: October 30th, 2010, 1:38 am
Location: Australia

Re: My vision was blocked. Please press OKAY (3000)

Postby glnc222 » March 20th, 2017, 10:31 pm

Difficult even with a digital camera as the beam is weak for safety and pulsing momentarily besides, unlike the bright LED emitters in the wall and cliff proximity sensors. Some fancy cameras have produced pictures of the lidar beam line on walls. But it is easy to check the lidar with the data scan over USB with the Neato Control Program. Besides the laser emitter there can be problems with the sensor related to digital camera tech.
glnc222
Robot Master
 
Posts: 4064
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: My vision was blocked. Please press OKAY (3000)

Postby Tritonal » March 21st, 2017, 5:20 pm

I am able to see it pulsing though very faintly when it was working properly. But now its a 50/50 on if it actually works. Yesterday morning it worked, afternoon it didn't and this morning to worked but stopped mid cleaning with a vision blocked 4000 then 3000. So it's very intermittent right now
Tritonal
 
Posts: 4
Joined: March 20th, 2017, 10:25 am

Previous

Return to Neato Robotics

Who is online

Users browsing this forum: Zikou and 414 guests