Neato Botvac Connected Not Charging

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Neato Botvac Connected Not Charging

Postby rmantech » December 18th, 2016, 4:43 pm

Hi, I have a neato botvac connected which is not charging and is losing charge despite flashing when put on the charging base; here are the neato control program readings, what do you think the problem may be?

Thanks

NEATO CONTROL PROGRAM READINGS

____ Analog: ____
BatteryVoltage mV=15785
BatteryCurrent mA=-112
BatteryTemperature mC=24100
ExternalVoltage mV=10692
AccelerometerX mG=14
AccelerometerY mG=4
AccelerometerZ mG=941
VacuumCurrent mA=0
SideBrushCurrent mA=0
MagSensorLeft VAL=0
MagSensorRight VAL=0
WallSensor mm=90
DropSensorLeft mm=0
DropSensorRight mm=0
____ Buttons: ____
BTN_SOFT_KEY False
BTN_SCROLL_UP False
BTN_START False
BTN_BACK False
BTN_SCROLL_DOWN False
BTN_SPOT False
IR_BTN_HOME False
IR_BTN_SPOT False
IR_BTN_ECO False
IR_BTN_UP False
IR_BTN_DOWN False
IR_BTN_RIGHT False
IR_BTN_LEFT False
IR_BTN_START False
IR_BTN_LEFT_ARC False
IR_BTN_RIGHT_ARC False
____ Charger: ____
FuelPercent 84
BatteryOverTemp 0
ChargingActive 0
ChargingEnabled 1
ConfidentOnFuel 0
OnReservedFuel 0
EmptyFuel 0
BatteryFailure 0
ExtPwrPresent 1
ThermistorPresent 1
BattTempCAvg 24
VBattV 15.78
VExtV 9.60
Charger_mAH 0
Discharge_mAH 112
rmantech
 
Posts: 6
Joined: December 18th, 2016, 4:36 pm

Re: Neato Botvac Connected Not Charging

Postby glnc222 » December 18th, 2016, 5:08 pm

I am not sure how you are observing that the battery is losing charge etc. However, there can be a defect in the unit or the dock requiring replacement under warranty. One way to reset and restart the entire charging process is to run the vacuum to discharge the battery as much as possible, until it demands a recharge. Look for a New Battery option on the LCD menus, which should reset the Per Cent Full fuel gauge (can also be done over USB with Neato Control or terminal emulator). Then try recharging on the dock again.

The charging computer program, the algorithm for lithium batteries, terminates charging at 16.8v on the battery terminals, based on voltage. When full, the battery raises its resistance to the charging current so the constant current (around 2 amps) charger raises its voltage to this terminating level. All done in software. In some chargers lithium continues to charge at 16.8v (for a series of four cells together) while current falls to zero; Vorwerk, who originally used lithium batteries in Neato, did not use this second topping off phase where little additional charge is added.

Another thing which could be at fault is the battery itself. The per cent fuel gauge could be based on an expected charge capacity written into the program. A defective or worn battery with lower capacity would terminate the charging by voltage, before the full per cent is reached. How exactly the program works is unknown. Symptoms of a worn battery are rapid charging and short run times.
glnc222
Robot Master
 
Posts: 4968
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato Botvac Connected Not Charging

Postby glnc222 » December 18th, 2016, 5:21 pm

Additional games to play: reset the Fuel Gauge manually over USB. Setting to zero would restart the charging which should quickly terminate at maximum voltage. Setting to 100 would stop charging and then see how much run time there is.
If recently bought at a store with a return policy, get it exchanged without involving Neato Robotics warranty.
glnc222
Robot Master
 
Posts: 4968
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato Botvac Connected Not Charging

Postby shirgal » December 18th, 2016, 6:59 pm

Your base charger output voltage is weak around 10vdc according to your print, should be at least 18vdc

I had one came in for repair last month with fluctuating voltage on the same charger you have.
Pcb is faulty,could be yours is same fault.
check with multimeter the voltage on the charger bars with and without the BOT attached.
User avatar
shirgal
Robot Addict
 
Posts: 160
Joined: July 8th, 2013, 10:54 am

Re: Neato Botvac Connected Not Charging

Postby rmantech » December 18th, 2016, 7:04 pm

Thanks for your replies guys, the strange thing is that sometimes it starts to charge perfectly meaning the neato android app shows a lightning sign on the battery level and it charges the battery quite quickly. Sometimes when the battery is showing 100% it suddenly starts to lose charge. And sometimes as last night there was no lightning sign on the app but it charged very slowly over night, even though in the beginning it appeared not to be charging at all. Hope some of that makes sense but that's how it's been behaving.
rmantech
 
Posts: 6
Joined: December 18th, 2016, 4:36 pm

Re: Neato Botvac Connected Not Charging

Postby rmantech » December 18th, 2016, 7:16 pm

shirgal wrote:Your base charger output voltage is weak around 10vdc according to your print, should be at least 18vdc

I had one came in for repair last month with fluctuating voltage on the same charger you have.
Pcb is faulty,could be yours is same fault.
check with multimeter the voltage on the charger bars with and without the BOT attached.


Thanks for your replies guys, the strange thing is that sometimes it starts to charge perfectly meaning the neato android app shows a lightning sign on the battery level and it charges the battery quite quickly. Sometimes when the battery is showing 100% it suddenly starts to lose charge. And sometimes as last night there was no lightning sign on the app but it charged very slowly over night, even though in the beginning it appeared not to be charging at all. Hope some of that makes sense but that's how it's been behaving.
rmantech
 
Posts: 6
Joined: December 18th, 2016, 4:36 pm

Re: Neato Botvac Connected Not Charging

Postby rmantech » December 18th, 2016, 8:04 pm

glnc222 wrote:Additional games to play: reset the Fuel Gauge manually over USB. Setting to zero would restart the charging which should quickly terminate at maximum voltage. Setting to 100 would stop charging and then see how much run time there is.
If recently bought at a store with a return policy, get it exchanged without involving Neato Robotics warranty.

Thanks for your replies guys, the strange thing is that sometimes it starts to charge perfectly meaning the neato android app shows a lightning sign on the battery level and it charges the battery quite quickly. Sometimes when the battery is showing 100% it suddenly starts to lose charge. And sometimes as last night there was no lightning sign on the app but it charged very slowly over night, even though in the beginning it appeared not to be charging at all. Hope some of that makes sense but that's how it's been behaving.
rmantech
 
Posts: 6
Joined: December 18th, 2016, 4:36 pm

Re: Neato Botvac Connected Not Charging

Postby glnc222 » December 18th, 2016, 8:41 pm

Personally I do not keep new tech products which aren't perfect on delivery. At least I want to start with it in proper condition. I don't know whether that app is showing any correct indication, either. Nothing has been said about how the robot runs. What does customer service say?
glnc222
Robot Master
 
Posts: 4968
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato Botvac Connected Not Charging

Postby rmantech » December 25th, 2016, 11:33 am

Hi,

Thanks for the reply, I actually bought the vaccuum second hand so cannot go to customer service, perhaps someone could suggest something?
rmantech
 
Posts: 6
Joined: December 18th, 2016, 4:36 pm

Re: Neato Botvac Connected Not Charging

Postby vic7767 » December 25th, 2016, 3:02 pm

Either your power supply is marginal or there is a defect on the main circuit board in the sensor charging portion. Also verify that all battery connectors (plug - jack) have good contact and no broken or loose wires.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14962
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato Botvac Connected Not Charging

Postby glnc222 » December 25th, 2016, 5:53 pm

Another member's charging problem was solved by resetting the system, rebooting
http://www.robotreviews.com/chat/viewtopic.php?p=141098#p141098
Charging is performed under software control, but hardware is also involved.
The charging system has many components in both the dock and in the robot, and complete information on the circuits is not available, though some links in Mods & Repairs list main forum page. For engineers.
glnc222
Robot Master
 
Posts: 4968
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato Botvac Connected Not Charging

Postby Uofmjock2 » October 18th, 2018, 1:02 pm

Hi, I bought a used neato Botvac D5 that did not include the charge base. I have a neato Botvac d80 and the charge base for it. I have tried charging the Botvac D5 with the d80's base and it charges but only very slowly. I've yet to get it to reach more than 80% charged. Do I need the charge base for the D5 of is there some other problem?
Uofmjock2
 
Posts: 2
Joined: October 18th, 2018, 12:56 pm

Re: Neato Botvac Connected Not Charging

Postby Uofmjock2 » October 18th, 2018, 1:09 pm

I should add that the same charge base charges my Botvac d80 to full in about 2 hours with no issues.The Botvac D5 has sat on the charger for up to 12 hours at a time.
Uofmjock2
 
Posts: 2
Joined: October 18th, 2018, 12:56 pm


Return to Neato Robotics

Who is online

Users browsing this forum: dboston55, ehasley, jdong, leonicholson, ps0001, RockinRay, someoneclever, vic7767 and 428 guests