Botvac D-series not recognising charger

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Botvac D-series not recognising charger

Postby Cylindric » February 4th, 2017, 8:05 am

Hi folks. I have a Neato Botvac D (Model 905-0285) that I got from eBay about 6 months ago. It looked brand new when I got it, the only problem was the bin kept popping open which is why it was passed on. It's been working fine since then, until recently when it simply stopped acknowledging the charging station.

When I push it up against the dock, nothing happens. No errors, just nothing. If I use NeatoControl to see what it is thinking, "ChargingActive" never changes. I do see that the "ExternalVoltage" goes from about 517mV when not touching the dock, to 158mV when touching he dock.

Can the dock be faulty? Is there an easy way to test if it is giving out power correctly? I assume I can't just put a meter on it and expect to get 18V @2A on it at all times.

Does anyone have any suggestions on getting life back into the thing? It currently has enough charge (reads at 12.175V at the moment) to start up happily enough, but immediately complains about low battery and gives up. I have tried "Service/New Battery".

thanks

Version:
Code: Select all
GetVersion
Component,Major,Minor,Build,Aux
BaseID,0.0,0.0,0,0,
BatteryType,1,NIMH_10CELL,
BlowerType,1,BLOWER_ORIG,
Bootloader Version,22009,,
BrushMotorType,1,BRUSH_MOTOR_ORIG,
BrushSpeed,1200,,
ChassisRev,1,,
DropSensorType,1,DROP_SENSOR_ORIG,
LCD Panel,137,240,124,
LDS CPU,F2802x/c001,,
LDS Serial,OPS10216AA-0129917,,
LDS Software,V2.6.15295,0000000000,
Locale,1,LOCALE_USA,
MagSensorType,1,MAG_SENSOR_ORIG,
MainBoard Serial Number,OPS05416,a0f6fd5b3c45,
MainBoard Version,0,,
Model,BotVacBasic,905-0285,
QAState,QA_STATE_APPROVED
Serial Number,OPS10316,a0f6fd5b3c45,P
SideBrushPower,1500,,
SideBrushType,2,SIDE_BRUSH_VORWERK_REV1,
Software,1,2,1
UI Board Hardware,0,0,
UI Board Software,1,3,
VacuumPwr,65,,
WallSensorType,1,WALL_SENSOR_ORIG,
WheelPodType,1,WHEEL_POD_ORIG,


Sensors:
Code: Select all
____   Discrete:   ____=
SNSR_DC_JACK_IS_IN=False
SNSR_DUSTBIN_IS_IN=False
SNSR_LEFT_WHEEL_EXTENDED=False
SNSR_RIGHT_WHEEL_EXTENDED=False
LSIDEBIT=False
LFRONTBIT=False
LLDSBIT=False
RSIDEBIT=False
RFRONTBIT=False
RLDSBIT=False
____   Analog:   ____=
BatteryVoltage=mV=12153
BatteryCurrent=mA=-101
BatteryTemperature=mC=18719
ExternalVoltage=mV=25
AccelerometerX=mG=0
AccelerometerY=mG=18
AccelerometerZ=mG=977
VacuumCurrent=mA=0
SideBrushCurrent=mA=0
MagSensorLeft=VAL=0
MagSensorRight=VAL=0
WallSensor=mm=70
DropSensorLeft=mm=0
DropSensorRight=mm=0
____   Buttons:   ____=
BTN_SOFT_KEY=False
BTN_SCROLL_UP=False
BTN_START=False
BTN_BACK=False
BTN_SCROLL_DOWN=False
BTN_SPOT=False
____   Charger:   ____=
FuelPercent=19
BatteryOverTemp=0
ChargingActive=0
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=0
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=0
ThermistorPresent=1
BattTempCAvg=18
VBattV=12.15
VExtV=0.01
Charger_mAH=0
Discharge_mAH=100
Cylindric
 
Posts: 4
Joined: October 6th, 2016, 6:03 pm
Location: UK

Re: Botvac D-series not recognising charger

Postby mfortuna » February 4th, 2017, 9:14 am

You can probably sneak a voltmeter in to take a direct reading but it sounds like the dock may be faulty. The dock senses when the robot makes contact and the voltage appears to change when you dock so the robot is probably OK.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
User avatar
mfortuna
Robot Master
 
Posts: 5780
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: Botvac D-series not recognising charger

Postby glnc222 » February 4th, 2017, 3:00 pm

Using the Neato Control Program or terminal emulator over USB, you can see all the charging measurements, battery terminal voltage (higher when charging), dock supply voltage, charging current, Fuel Gauge per cent. If the battery is not already full the ring light on the vacuum should blink as charging occurs and the data should show charging current (around 2 amps). There is a power management IC in the dock for shock hazard protection among other things, so failure to communicate with the dock about connection may prevent charging. I think on the 12v battery system the dock voltage is 18v. Off the dock a full battery can be over 13v, down to 12 and below when discharged.
glnc222
Robot Master
 
Posts: 4613
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Botvac D-series not recognising charger

Postby Medtech » February 19th, 2017, 3:01 pm

You should measure the voltage at the terminals without base multimeter robot report to check the cord just in case the power.
Thank you GOOGLE translator for the freedom of communication.
User avatar
Medtech
Robot Addict
 
Posts: 133
Joined: October 17th, 2014, 3:12 pm
Location: Moscow Russia


Return to Neato Robotics

Who is online

Users browsing this forum: a1robotrepair, aarolar and 465 guests

cron