lidar not spinning with new motor

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

lidar not spinning with new motor

Postby dand99 » August 30th, 2017, 12:28 am

So my neato connected started giving a 3000 error and, upon inspection, I noticed the lidar was not spinning at all. I ordered a new lidar motor and installed it. Unfortunately the lidar still does not spin. I measured the voltage where the motor connects to the motherboard and found that the voltage spikes then drops to zero. I'm stuck at this point as I thought a new lidar motor would fix it, but now I'm fearing it's the motherboard. Anybody have any suggestions?
dand99
 
Posts: 4
Joined: August 30th, 2017, 12:21 am

Re: lidar not spinning with new motor

Postby Medtech » August 30th, 2017, 7:39 am

It is necessary to connect the motor to a constant current source with a voltage of 2.8-3.3V. To check the rotation of the engine, the lidar should rotate counter-clockwise. Inspect the fee carefully on the left side, usually the damage is visible to the naked eye.
Thank you GOOGLE translator for the freedom of communication.
User avatar
Medtech
Robot Addict
 
Posts: 126
Joined: October 17th, 2014, 3:12 pm
Location: Moscow Russia

Re: lidar not spinning with new motor

Postby dand99 » October 2nd, 2017, 10:06 pm

I have connected the motor to an external power source and can confirm that it works. I have tried changing the polarity of the connector by swapping the position of the red and black cables. Yet regardless of how I connect the motor to the motherboard it does not begin to spin when a cleaning cycle begins.
dand99
 
Posts: 4
Joined: August 30th, 2017, 12:21 am

Re: lidar not spinning with new motor

Postby vic7767 » October 2nd, 2017, 10:42 pm

The Lidar motor requires a PWM signal sent from the main board in order to maintain 300 RPMs. The motor tests OK if external power spins the motor shaft. The PWM controller is not working.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14385
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: lidar not spinning with new motor

Postby dand99 » October 2nd, 2017, 11:21 pm

Then what part would I need to fix it?
dand99
 
Posts: 4
Joined: August 30th, 2017, 12:21 am

Re: lidar not spinning with new motor

Postby vic7767 » October 2nd, 2017, 11:42 pm

So far no-one has identified the component responsible for the PWM signal. Most owners replace the main circuit board.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14385
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: lidar not spinning with new motor

Postby Medtech » October 3rd, 2017, 4:50 am

dand99 wrote:Then what part would I need to fix it?

The fault is usually located in the place circled in red.
2017-10-03_11-40-02.jpg
Thank you GOOGLE translator for the freedom of communication.
User avatar
Medtech
Robot Addict
 
Posts: 126
Joined: October 17th, 2014, 3:12 pm
Location: Moscow Russia

Re: lidar not spinning with new motor

Postby dand99 » October 3rd, 2017, 9:34 am

I've looked for a replacement main board, but have not found one. If you know, could you please tell me how to acquire one.
dand99
 
Posts: 4
Joined: August 30th, 2017, 12:21 am

Re: lidar not spinning with new motor

Postby vic7767 » October 3rd, 2017, 10:13 am

The only source for a Neato Robotics replacement parts is from a donor robot. Check ebay for a Botvac Connected robot PCB or even a "for parts only" robot.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14385
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: lidar not spinning with new motor

Postby glnc222 » October 3rd, 2017, 11:51 am

They have appeared on ebay from time to time, at least for XV models. A number of those were acquired just to remove the lidar for other robotics uses.
glnc222
Robot Master
 
Posts: 4582
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: lidar not spinning with new motor

Postby vic7767 » October 3rd, 2017, 3:04 pm

It would probably be best to just purchase the newer Botvac D3. Still uses the WiFi app and the Liquid Crystal Display User Interface has been removed. One less part to fail.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14385
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to Neato Robotics

Who is online

Users browsing this forum: inetchik, longerski, Snokia, susantx3 and 298 guests