XV11/VR100 lost settings

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

XV11/VR100 lost settings

Postby seattle » August 31st, 2017, 12:36 pm

Hello!

First, great board! Could find a lot of hints to check my VR100 but now I'm stuck.
After 2 weeks of vacation I found my VR100 standing in the middle of my room with empty batteries. I recharged but the VR100 always came up with battery errors.
After reading this board, I connected with putty and entered "getversion".
This is what I got:

getversion
Component,Major,Minor,Build
ModelID,-1,,
ConfigID,-1,,
Serial Number,AAAnnnnnAA,0000000,P
Software,3,2,18755
BatteryType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
BlowerType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
BrushSpeed,1450,,
BrushMotorType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
SideBrushType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
WheelPodType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
DropSensorType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
MagSensorType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
WallSensorType,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
Locale,-1,Illegal value (-1) for Enum type ESCBBatteryType.,
LDS Software,V2.6.15295,0000000000,
LDS Serial,KSH44312AA-0075147,,
LDS CPU,F2802x/c001,,
MainBoard Vendor ID,0,,
MainBoard Serial Number,0,,
MainBoard Version,7,1,
ChassisRev,-1,,
UIPanelRev,-1,,

Seems it lost all its settings. I tried with "setconfig" to enter correct values for VR100 but it's still not working.
Is there a way to regain all original VR100 settings?
I do have access to another VR100. Can I copy the settings from one to another?

VR100 (Vorwerk Kobold), Cruz, Rev 113

Thanks!
seattle
 
Posts: 1
Joined: August 31st, 2017, 12:19 pm

Re: XV11/VR100 lost settings

Postby glnc222 » August 31st, 2017, 1:37 pm

On the XV models, Rev113 Cruz boards, the SetConfig command was found not enabled in software, even though the command might not show an error during comm. It works only on the later Rev64 Binky boards.
The lost data also suggests a defect in the cpu and memory components. So if reflashing the firmware, available at Vorwerk or the captured files in some thread here, the defect could disrupt the procedure and damage the system (flashing is actually performed by the robot itself, requiring some software integrity). However, what's to lose?

Flashing is a function in the USB command language, used with a custom terminal emulator and scripts updater program in the USB driver install package.
glnc222
Robot Master
 
Posts: 4447
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Neato Robotics

Who is online

Users browsing this forum: dex1i38, doublem, Kelad, moonlightshaker and 252 guests