Switch to full style
News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.
Post a reply

Neato cleans just small spot and stops. Need advice.

September 12th, 2017, 4:07 am

Hello!
Less than 2 years ago I’ve bought Neato Signature XV. A week ago it stopped working. I noticed that menu button was stuck. My Neato still had warranty, but I bought it in Germany, and now I live in Lithuania. Also the problem looked quite simple, so I’ve decided to repair it on my own. I’ve disassembled it, fixed button (I just needed to tighten the nut near it) and assembled it back. It start worked but new issue appeared. Now when I launch the cleaning, my Neato just cleans some spot, not the entire room, and then says that cleaning is finished, and returns back to the base. I double checked everything, cleaned the “fall” sensors. Even cleaned the laser windows (with care), but problem still exists.
Could you please suggest, maybe it is know issue, and you could advice how to fix it?
Thank you in advance!

Re: Neato cleans just small spot and stops. Need advice.

September 12th, 2017, 9:21 am

Make sure the sensor that senses through the front corner of the bumper is correctly connected, correctly located, and clean.

Re: Neato cleans just small spot and stops. Need advice.

September 12th, 2017, 2:32 pm

Install the Neato Control Program and check the sensors over USB.
One cause of the problem is failure of the Wall Sensor, which can give a false indication of walls around the robot leaving nothing to clean.

Re: Neato cleans just small spot and stops. Need advice.

September 13th, 2017, 5:59 am

Thank you!
The sensor in the front corner was connected vise versa.
Now everything works fine.
Post a reply