Neato connected 0001 error.

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Neato connected 0001 error.

Postby --telly-- » October 7th, 2017, 10:47 am

Hello, I have a neato connected 85 that has a 0001 error. It randomly reboots and the resets so I have to set the clock and language again. I've charged the battery using an external charger but this has not stopped the error. I've also noticed that if you have the neato on charge then pull it away it will "nudge" back onto the charger station.

I can find any info on the 0001 error on the internet. I've opened it up as it's out of warranty and everything looks ok and I've thested the bump buttons with a multimeter and it all looks ok.


Any help would be great. Thanks telly! :D
--telly--
 
Posts: 3
Joined: October 7th, 2017, 10:40 am

Re: Neato connected 0001 error.

Postby JEfromCanada » October 7th, 2017, 5:49 pm

FYI, the 85 and D85 are not among the "Connected" (i.e. WiFi) models. The nudging behaviour you witnessed is standard for all Neato vacs (the earliest versions incorporated this feature with a firmware update).

You should get your hands on the Neato control software authored by a member of this forum. It allows you to connect your bot to your computer via USB cable to test the various sensors and switches. Find out more in this thread: viewtopic.php?t=18173

Sorry, but I don't know what an error 0001 is.
Current robots:
Roomba Discovery 4210 (R.I.P. - Freecycled)
Roomba 560 (retired)
Neato XV-11 SW version 3.1.17844, LDS version 2.6.15295, with Pet Brush and Vic's filter (sold)
Neato Botvac 80 SW version 1.1.97, LDS version 2.6.15295, Board SW version 22753
JEfromCanada
Robot Addict
 
Posts: 623
Joined: November 13th, 2007, 5:16 pm
Location: Canada

Re: Neato connected 0001 error.

Postby --telly-- » October 8th, 2017, 3:23 am

Hi, I had some success last night with the software. When doing a hard reset I can see everything in the 'get version' window and a clean cycle can be run fully. The problem is when changing the UI to English it reboots the UI and it shows 'illagal value' for the battery, blower, brush etc in the 'get version' window. Then the 0001 error comes back. No data is shown about the battery level and the charge cycle won't start. The blower, brush etc will work in the motors tab, even the lidar works correctly and sees objects around.

Even changing the UI language using the software has the same result.

So currently my neato is stuck in Chinese.
--telly--
 
Posts: 3
Joined: October 7th, 2017, 10:40 am

Re: Neato connected 0001 error.

Postby Medtech » October 8th, 2017, 1:18 pm

You need to replace the board, the robot has lost the configuration file, there are no values for it, these data are in the controller, but there are no firmware for the controllers and the ability to make changes to the configuration file.
Only the replacement of the board will help.
Thank you GOOGLE translator for the freedom of communication.
User avatar
Medtech
Robot Addict
 
Posts: 133
Joined: October 17th, 2014, 3:12 pm
Location: Moscow Russia

Re: Neato connected 0001 error.

Postby --telly-- » October 10th, 2017, 1:40 pm

Thank you for that information. I will look out for a new board, but they are hard to come by and expensive. Anyway I'll keep running in Chinese till thank you!
--telly--
 
Posts: 3
Joined: October 7th, 2017, 10:40 am

Re: Neato connected 0001 error.

Postby Medtech » October 12th, 2017, 5:46 pm

While you are searching, you can buy a regular board from any Botvac and a metal hydride battery, you will have a working robot without a Wi-Fi. But it will work and clean your house. It's better than nothing and much cheaper than a board for Connect.
My language is Russian - vodka, valenki, balalaika.
2017-10-13_00-42-56.jpg
2017-10-13_00-42-56.jpg (3.65 KiB) Viewed 642 times
Thank you GOOGLE translator for the freedom of communication.
User avatar
Medtech
Robot Addict
 
Posts: 133
Joined: October 17th, 2014, 3:12 pm
Location: Moscow Russia


Return to Neato Robotics

Who is online

Users browsing this forum: Kelad, uoficowboy, vic7767 and 525 guests