Connecting to xv11 through serial

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Connecting to xv11 through serial

Postby Vetekli » November 13th, 2017, 6:32 pm

Hi!

The screen on my old xv-11 is broken, so i usually configure it through the serial (USB) port. The bot has not been used for some time so i dont have the same PC anymore. I cant connect to it through putty!

I installed NeatoUpdaterTool and im using the driver "Neato Robotics USB Port" version 1.0.0.0.
When i connect through Putty 0.69 it says "Ignoring detected battery type because XV11" and the bot "dies" (like when it goes to sleep) and putty says "Error reading from serial device".

Im running Windows 10 64-bit, has anyone got this to work? I cant schedule my bot without it. :(
Vetekli
 
Posts: 26
Joined: September 17th, 2011, 3:20 pm

Re: Connecting to xv11 through serial

Postby glnc222 » November 13th, 2017, 8:08 pm

Not sure if helps but there are separate 32-bit and 64-bit versions of the updater/driver package (installs an updater tool, script driven terminal emulator) along with the USB driver, used for firmware updates only)
USB "updater tool" driver Neato website from updating link in MyNeato
64-bit: http://www.neatoroboticsupdates.com/NeatoInstaller/NeatoUpdaterToolInstaller_x64.exe
32-bit
http://www.neatoroboticsupdates.com/NeatoInstaller/NeatoUpdaterToolInstaller_x86.exe
--unsigned driver in Windows 8.1 (maybe 10 as well?) requires over-riding prohibition globally in advanced settings; local prompts from installations ignored, misleading.

Certain old AMD/Nvidia PC's and laptops had a system board driver defect preventing exclusively Neato's unusual protocol (reproducing older RS232, teletype character by character com, single character packets). Neato echos characters and performs backspace editing on lines. Intel comps good.

Neato's can go to sleep and shut com some times, press start to relight the LCD and resume com.
glnc222
Robot Master
 
Posts: 4582
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Connecting to xv11 through serial

Postby Vetekli » November 14th, 2017, 6:58 am

Thanks, but i cant get it to work anyway sadly. The x64 version is the one i have installed. The driver is there in the device manager so it looks ok. I tried 3 different PCs, on the other i had Win 7 and they behaved differently. I can connect but the session just hangs. Im hoping i managed to set the clock and enable the schedule now by watching youtube videos of the menus..
Vetekli
 
Posts: 26
Joined: September 17th, 2011, 3:20 pm

Re: Connecting to xv11 through serial

Postby glnc222 » November 14th, 2017, 1:06 pm

iPads are getting known for dirt in the cable connector needing cleaning (though there is a cover on the Neato port). And try another cable.
glnc222
Robot Master
 
Posts: 4582
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Neato Robotics

Who is online

Users browsing this forum: Bandi94, Franzl, inetchik, longerski, Snokia, teokakav, vic7767 and 444 guests