Neato Connect - Press OK to Continue – Firmware re-install?

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby keebler86 » March 1st, 2018, 8:28 pm

TechGuy wrote:You need to determine what is your LIDAR doing or not doing before deciding what need to replace.
If the LIDAR is not turning, test the motor with a battery.
If the motor is working, is the motor turning at correct RPM.
If the LIDAR is not turning at correct RPM, the belt may be stretched and/or motor is no good.


I can confirm the LIDAR motor is turning, as the LIDAR turret is spinning during the 3X start/stop sequence.
I don't know how to ensure the motor is spinning at the proper RPM. - Can the LIDAR motor or LIDAR turret RPM be measured using NeatoControl?
The LIDAR belt does not appear to be damaged, cracked, or broken, but I suppose it is possible for it to have stretched and be slipping slightly.
As a reference, my Botvac is about 2 years old and has never had either belt replaced. The side brush belt does have cracking but is not fully broken, and seems to have stretched to a point that the brush no longer spins.

I will plan to replace both the LIDAR and side brush belts, as the side brush belt needs replaced anyway.
keebler86
 
Posts: 5
Joined: February 27th, 2018, 12:21 am

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby phil1464 » January 5th, 2019, 7:30 pm

Techguy, I just recently have similar press OK to continue (3000) problem for a 2016 botvac connected. Will be ordering from vic a new lidar motor with cable and from ebay a new drive belt (the current belt has about 3/8" give when pressed lightly). These are first 2 replacements to try and maybe a new laser diode before looking for a replacement lidar unit. BTW, does anybody know if the D3, D5 connected lidar unit will also work with the original connected? I'm spending way too much time on this, but it's interesting robotic stuff. Thanks
phil1464
 
Posts: 5
Joined: January 5th, 2019, 7:12 pm

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby HiTec » January 5th, 2019, 8:48 pm

New D series Lidar has a different style motherboard than previous versions. It houses motor drive connectors etc. I'm not sure if you can remove the motherboard and replace it with original Connected motherboard.

Replacement laser diode from china costs about 10 dollars on ebay. Might be tricky to focus it correctly though. With the help of NeatoConnect, it should be possible.
HiTec
Robot Groupie
 
Posts: 90
Joined: February 8th, 2015, 8:17 am

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby phil1464 » January 5th, 2019, 9:31 pm

Thanks. Is there a good link or website for Neatoconnect instructions, with details for a simple test rig and power required to test the lidar and check or calibrate the current lidar’s laser operation? Thanks, I’m new to robotics but am persistent and can learn quick.
phil1464
 
Posts: 5
Joined: January 5th, 2019, 7:12 pm

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby vic7767 » January 5th, 2019, 11:07 pm

phil1464 wrote:a simple test rig and power required to test the lidar and check or calibrate the current lidar’s laser operation?

Go here and scroll down the subjects until you find the Lidar links:

viewtopic.php?f=20&t=16475#p110868
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14896
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby HiTec » January 6th, 2019, 7:25 pm

Replace laser diode and try to get it as closely to same position as the previous diode, download newest neatocontrol, connect the robot to pc via usb, open neatocontrol, enable test mode, check lds page and enable scanning. Robot should see 3-5 meters around it. If it doesnt, open lidar cap and rotate laser diode, or the receiver lens. Once rotated, test again. Repeat until robot sees correctly.

Edit: Before changing laser diode, check with neatocontrol how bad the robots vision currently is. It might just be a lens focus problem if the lidar is spinning the correct 5Hz.
HiTec
Robot Groupie
 
Posts: 90
Joined: February 8th, 2015, 8:17 am

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby phil1464 » January 6th, 2019, 9:54 pm

Thanks HiTec! I will check current unit operation with a teensy board and try the neatocontrol also.
phil1464
 
Posts: 5
Joined: January 5th, 2019, 7:12 pm

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby redpoint5 » January 7th, 2019, 12:56 pm

I've experienced both the laser failing to come on, and now a slowly turning turret on my xv-11. It acts like the O ring is slipping because it kinda of stutters as it turns, but last I checked, it looked just fine. I want to fix the thing since I invested in lithium ion batteries and a new brush, but I'm spending way more time fiddling with the thing than I save with it cleaning. I suppose I'm willing to try a new O ring and possibly a new motor. Don't really want to fiddle with soldering lasers and messing with focus. Seems unlikely to me that the laser diode would fail anyhow. I'd suspect something like capacitors before a laser failure.
redpoint5
Robot Groupie
 
Posts: 50
Joined: December 20th, 2013, 4:06 pm

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby HiTec » January 7th, 2019, 5:41 pm

If i recal correctly, XV series uses slip ring style power delivery to lidar laser, whereas Botvacs use inductive style. That might be another cause for your XV problems.
HiTec
Robot Groupie
 
Posts: 90
Joined: February 8th, 2015, 8:17 am

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby redpoint5 » January 7th, 2019, 7:47 pm

Oh interesting, thanks HiTec. I'm guessing that unit is sealed, and I don't want to crack into it to look at the slip ring?

Laser has been turning on lately, so hopefully it holds out. Maybe giving it a kick would get it going too if it fails in the future.

With the D3 going for as low as $150 new (and I got one), it's hard for me to justify spending lots of time working on the old unit. Learning about it still interests me though, and I'd hate to send it to the trash if it has a lot of life left.

The LIDAR unit is the only thing that has caused me grief so far. The batteries were terrible too, but since replacing with lithium ion have been great. The stock beater brush was noisy and the bearing eventually too, but that was easy and cheap to replace.
Last edited by redpoint5 on January 8th, 2019, 1:11 pm, edited 1 time in total.
redpoint5
Robot Groupie
 
Posts: 50
Joined: December 20th, 2013, 4:06 pm

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby HiTec » January 8th, 2019, 8:01 am

No problem. I think you can disassemble the slip ring. I dont have XV, so i cant offer more help with that. But once open, you could inspect if theres a wear or dirt in there.
HiTec
Robot Groupie
 
Posts: 90
Joined: February 8th, 2015, 8:17 am

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby phil1464 » January 12th, 2019, 6:22 pm

HiTec,

I've got the Neato Control ver 3.3 running with my botvac connected lidar connected to a teensy board.

It's spinning but can't seem to get data displayed. I've enabled test mode, checked boxes scan LDS and show state under scanner menu. Am I missing any control or data display boxes to check?

I have a steady black line pointing at about 11:00 oclock. Maybe time to turn the laser diode to see if state changes?
phil1464
 
Posts: 5
Joined: January 5th, 2019, 7:12 pm

Re: Neato Connect - Press OK to Continue – Firmware re-insta

Postby phil1464 » January 12th, 2019, 6:40 pm

I changed the COM port to COM3 and it's recording data but greek to me. The scanner page display is now a red line at 11:00 oclock with multiple concentric black circles.
phil1464
 
Posts: 5
Joined: January 5th, 2019, 7:12 pm

Previous

Return to Neato Robotics

Who is online

Users browsing this forum: clone1008, fufu, im1kissfan, jdong, johnnyh, leonicholson, raidencmc, Rar9, vic7767, vicdeng and 395 guests

cron