Neato XV got dumber?

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Neato XV got dumber?

Postby humanoid » January 28th, 2018, 3:08 am

My trusty XV which has been working for years got really dumb in the last year.
When I got it I was impressed how methodically it cleans the house room by room and never miss a spot.

In the last few months it got dumb. I am now watching it clean the same room the third time in one run. It never did that before and my flat hasn't changed.
In addition it tends to get stuck in corners going back and forth, corners which it never had a problem with.
Finding the charger used to be a simple process, now it goes to the other side of the room, try to dock on random walls and what used to take two minutes can take over 10 (and occasionally fail)

On Neato control the laser map looks perfect, all sensors are working as normal, and it is running the same version of the software from day one. Battery runs at least 40 min.

It's not the sensors, and I cannot see how it can be software, since the software is the same.

Any ideas?
humanoid
Robot Groupie
 
Posts: 93
Joined: January 2nd, 2016, 7:19 pm

Re: Neato XV got dumber?

Postby Brett » January 28th, 2018, 10:08 am

Time flies like an arrow.
Fruit flies like a banana!
User avatar
Brett
Robot Addict
 
Posts: 297
Joined: November 2nd, 2009, 8:50 pm
Location: Perth, Western Australia

Re: Neato XV got dumber?

Postby nadcicle » January 29th, 2018, 6:30 pm

Brett wrote:http://www.robotreviews.com/chat/viewtopic.php?f=20&t=19076


(-8


Thanks for posting this. I searched all around for other issues like the OP here posted and didn't know how to explain it.

Neato XV got dumber was an excellent description! I also like the "Drunken Neato" as well.

Good ways to describe said issues!
nadcicle
 
Posts: 9
Joined: January 2nd, 2018, 6:00 pm

Re: Neato XV got dumber?

Postby humanoid » February 11th, 2018, 6:29 pm

Brett wrote:http://www.robotreviews.com/chat/viewtopic.php?f=20&t=19076


(-8

Thanks. Under vacuum load I get 13.5 volt. Vacuum without filter goes down to 12V. Is that the reason?

As far as replacing capacitors, I have the older board which is hard to disconnect from the screen (more accurately hard to reconnect the screen) so I don't want to touch it. I am also not sure its the cause because the symptoms are not the same as other people, and it seems that the capacitors do not always solve navigation problems.
humanoid
Robot Groupie
 
Posts: 93
Joined: January 2nd, 2016, 7:19 pm

Re: Neato XV got dumber?

Postby glnc222 » February 11th, 2018, 7:48 pm

If you look at thread "Electronic Filter Monitoring" you will see that the power load of the fan is substantially increased if the filter is left out. The fixed RPM speed regulation reduces power as the filter clogs, having less air to move -- the opposite of some full size vacuums. Leaving out the filter would reduce the run time.

12v is an extremely low, minimum level for the XV batteries, below which damage to cells can occur. A worn out battery with lost capacity could reach this level under load, a sign the battery needs replacement. The 13.5v mentioned is a level about where the Neato will return to base -- maintaining a buffer of unused capacity against damaging deep discharge, and a reserve for returning to base.

I have to wonder if the abnormal travel observed is a mode where it is searching for a base to recharge, though it would normally follow a map for that if launched from the base.

When replacing the battery, the "New Battery" option in the LCD menu must be used, as the system monitors loss of battery capacity with age, maintaining reserves with shorter run time, and needs to be reset.

Any kind of power supply deficiency as from an inadequate battery can disrupt the computer operations in unpredictable ways. Diagnosing hardware defects requires a known good battery to begin with to identify faults correctly.

A worn out or defective battery can show the same voltage unloaded as good ones, with the lost capacity showing up only under load and in shorter run times. Any NiMh battery used more than 200 charging cycles can be suspect.
glnc222
Robot Master
 
Posts: 4697
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Neato Robotics

Who is online

Users browsing this forum: aarolar, chefkeith, johnnyh, Metalworker and 369 guests