BotVac 80 Beeps while charging

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

BotVac 80 Beeps while charging

Postby supradupafast » February 11th, 2018, 1:14 pm

Hello all.

I have a Neato BotVac80 with charging issues. Batteries are great, and it will clean without issues.
The issue is, it won't stop beeping and displaying "Thank you for cleaning my bin" when it is connected to charger.
Has anyone experienced this ? It's been a issue for a while, so I had just "parked it" in OFF mode for a while, but I would hate wasting a good working robot..
I've tried the "shut down", pulling and reinstalling batteries.. Same issues..

Thank you in advance.
User avatar
supradupafast
 
Posts: 45
Joined: January 5th, 2013, 6:40 pm

Re: BotVac 80 Beeps while charging

Postby glnc222 » February 11th, 2018, 3:44 pm

That message occurs when the bin is opened and then closed, sort of confirming it was opened for cleaning.
There might be a borderline defect in the switch or closure of the bin causing momentary interruptions which the computer sees as opening the bin and then closing.
There have been a number of defects in the bin fitting to press on the switch, where it never closes, with various mechanical fixes, tape or what not.
I believe there is a microswitch for this sensor in the Botvac though I never examined that part. There have been similar issues with the Vorwerk version VR200.
A worst case is the signal is not processed properly by the cpu, some fault in the cabling or in the cpu itself, though never reported on this problem.

I would avoid bypassing the switch because the software may request opening the bin after some time to insure it is emptied, requiring opening and closing the switch in order to run.
glnc222
Robot Master
 
Posts: 4746
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: BotVac 80 Beeps while charging

Postby supradupafast » February 11th, 2018, 9:21 pm

Thank you for the reply.
I have played around and "shimmed" the switch as I thought it the issue was that it wasn't pressed down enough, but does not seem to fix.
User avatar
supradupafast
 
Posts: 45
Joined: January 5th, 2013, 6:40 pm

Re: BotVac 80 Beeps while charging

Postby Brett » February 11th, 2018, 10:07 pm

Might be dirt accumulated under the the rubbery "button" preventing good contact strip the unit and lift the back of the pcb (you don't have to remove it completely, but you must have removed the battery beforehand otherwise the batt connector will prevent lifting the pcb). Pull the rubber thingo off and wipe clean (both). Re-install (pull the two rubbery fingers through with tweezers to seat properly).

Test and report back...

(-8
Time flies like an arrow.
Fruit flies like a banana!
User avatar
Brett
Robot Addict
 
Posts: 325
Joined: November 2nd, 2009, 8:50 pm
Location: Perth, Western Australia

Re: BotVac 80 Beeps while charging

Postby glnc222 » February 12th, 2018, 3:35 am

The rubber plunger onto board contacts is on the XV models but I am not sure about Botvac, which may have a microswitch instead, I never examined it closely. The XV contacts are exposed to some dirt and can be cleaned well with alcohol. Some people have shorted the switch closed with a jumper wire. When a "please empty bin" message occurs you would reboot by turning off the battery switch -- some VR200 problems posted in Germany and France.
glnc222
Robot Master
 
Posts: 4746
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: BotVac 80 Beeps while charging

Postby Brett » February 12th, 2018, 8:07 am

Botvac has the same...

(-8
Time flies like an arrow.
Fruit flies like a banana!
User avatar
Brett
Robot Addict
 
Posts: 325
Joined: November 2nd, 2009, 8:50 pm
Location: Perth, Western Australia


Return to Neato Robotics

Who is online

Users browsing this forum: BCCISProf, im1kissfan, jdong, johnnyh, mfortuna, Miles267, Russo221, vic7767 and 355 guests