Thanks to you all! I brought a Botvac 80 back to life!

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Thanks to you all! I brought a Botvac 80 back to life!

Postby Hooten » October 10th, 2018, 11:50 am

Hi!
I picked up a very clean Botvac 80 at a thrift store for about $70. It appeared to work when I tested it and seemed to only need light cleaning and a battery charge.

It ended up having problems with the bin door switch, the battery on/off switch, the battery connector and a lot of intermittent weirdness. I spent about an hour here reading about problems/solutions from others and went to work.

    I took it apart using the tear down instructions on iFixIt.
    Re-soldered the battery switch and the battery connector on the main board and crimped the connectors on the battery where they had spread. I also used an external charger on the battery while I put the robot back together.
    Cleaned the bin door switch and added light silicone lubricant to the rubber where it exits the top cover.
    After installing the main board and connectors, I pressed in all the wires to their connector housings. Many had backed out.

After an overnight charge I sent it on an inaugural cleaning mission and it worked great!

Thanks for all your posts. They saved me from hours of troubleshooting and I was able to get it running on the first try! :clap:
Hooten
 
Posts: 1
Joined: October 10th, 2018, 11:26 am

Re: Thanks to you all! I brought a Botvac 80 back to life!

Postby vic7767 » October 10th, 2018, 12:19 pm

:cheers:
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14780
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA


Return to Neato Robotics

Who is online

Users browsing this forum: 911medic, jramer, mfortuna, shirgal, sshephard and 117 guests