Botvac 85 Technical woes

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Botvac 85 Technical woes

Postby zephar » November 28th, 2018, 2:10 am

So my luck I bought a certified refurb vacuum off of ebay and it basically ran fine until the 60 day mark :P., I did some research and I was really hoping the only issue was going to be the bumper switch malfunction. Which I took it apart and fixed today. I now makes the trip around by almost seems liek the vacuum is blind. Has to constantly check walls. My older XV-21 does seems to see where its going alot better. I wondering if its the linar or the wall sensor. Any tips on testing this with the NeatoControl - program for diagnostic ?

EDIT

PS
Other times I swear it may be the memory or something on the vacuum as ill see it repeating cleaning the same areas again 15 minutes later.
zephar
 
Posts: 3
Joined: November 28th, 2018, 1:09 am

Re: Botvac 85 Technical woes

Postby HiTec » November 28th, 2018, 8:47 am

Definitely lidar problem. Connect with neato control and check how far the lidar sees. Range should be 3-5 meters.

If not, check that the lenses are clean. Then try to adjust the receiver lens focus by turning the lens. Check with neatocontrol after each adjustment. Repeat until its good.
HiTec
Robot Groupie
 
Posts: 72
Joined: February 8th, 2015, 8:17 am

Re: Botvac 85 Technical woes

Postby glnc222 » November 28th, 2018, 6:37 pm

Neato Control tests sensors like bumpers, wall sensor, cliff sensors, mag strip sensors by continuously polling for status, showing it on screen as it changes. So for the wall sensor, move a hand close and away from it and observe the change. The symptom of wall sensor failure is typically moving in a circle with a phantom wall detection.
Some sensors, maybe mag strips, not sure which, require Test Mode set with the "TestMode ON" command. Neato Control invokes this automatically only for motor tests I think. You must not unplug the cable without properly exiting the program so it automatically issues the "TestMode OFF" command, or it must be issued manually -- the Neato does not automatically exit the mode, and it will not clean in that mode, as it is set for individual motor tests.
glnc222
Robot Master
 
Posts: 4837
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Botvac 85 Technical woes

Postby zephar » November 30th, 2018, 1:32 am

Thanks guys, I'll try to make time tomorrow to test out the above and put up some snapshots of any test results I got questions on.
zephar
 
Posts: 3
Joined: November 28th, 2018, 1:09 am

Re: Botvac 85 Technical woes

Postby zephar » December 10th, 2018, 2:15 pm

Really strange, I ran it one more time before I was going to run the test and the sucker started working better then it originally did when I got it. seeing how its working now its clear that it is the wall sensor. Oringinally when I got it it bugged me that it did not hug the wall as close as my old XV did. (thought it was just how it worked.) then it started where it would keep hitting the wall. Now its hugging the wall like my old XV and is working fine. No clue why it decided to start working right. It did have a bumper switch that was not responding that I fixed. Which is when it was still acting up. No clue why 3 runs later it decided to work well better then ever. Has been working great consistantly for over a week now so go figure!!! If it acts up again ill do what was suggested and see what happens.

Could I replace the wall sensor with one of the floor sensors (If it starts acting up again?) I have no stairs

thanks again
zephar
 
Posts: 3
Joined: November 28th, 2018, 1:09 am

Re: Botvac 85 Technical woes

Postby glnc222 » December 10th, 2018, 9:21 pm

See this thread regarding the cliff and wall sensor (same part).
http://www.robotreviews.com/chat/viewtopic.php?f=20&t=18637&hilit=cliff+sensor+resistor
If you do not want to buy one (Sharp component alone or assembly with cable used on Ebay) for the wall sensor, the borrowed cliff sensor must be replaced by a resistor divider to provide the close proximity floor output voltage to the cpu, say a total 200K ohms divided as needed, from the 5v power line.
glnc222
Robot Master
 
Posts: 4837
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Neato Robotics

Who is online

Users browsing this forum: Aniseedvan, joanquro, lanchez, Metalworker, RockinRay and 366 guests