Switch to full style
News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.
Post a reply

Neato D7 4.3.1 issue

December 6th, 2018, 5:36 am

I updated my D7 to 4.3.1 yesterday and now the D7 gets stuck every time with message "clean brush" when it tries to go on my carpet with tassels. I've had my D7 for 6 months and it has never before got stuck on the tassels on this carpet. I tried 4 times yesterday and all times it got stuck with the error message.

I think this update included changes to the sensitivity of when the D7 thinks the brush is stuck.

Anyone with similar problem after the 4.3.1 update or any tips?

Re: Neato D7 4.3.1 issue

December 6th, 2018, 12:45 pm

Perhaps the Eco or Turbo mode is back to default setting.
Did you set it to Eco before?
I can remember this issue when the suction power is set to Turbo. Try Eco instead.

Re: Neato D7 4.3.1 issue

December 7th, 2018, 3:51 am

It's on Turbo mode, I have never tried Eco mode.

I have come up with another possible reason for this: When it got stuck 4 times, I was trying to use the zone cleaning function all four times and maybe the D7 cleans that room in a different order with zone cleaning?

I will try it out.

Re: Neato D7 4.3.1 issue

December 12th, 2018, 5:53 pm

Not going to start a new thread, will post it here. Mod please move if necessary.

Just started running the 4.3.1 firmware on three D3 robots. Buggy as heck on all three. Hopefully, a patch is in the works.

Also, any news on an aftermarket battery?
Post a reply