Switch to full style
News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.
Post a reply

D3 "jumpstart" lidar question

December 30th, 2018, 9:59 pm

I want to say thank you to all of the people on this forum that have helped by either reading their solutions, or looking at their advice.

The TLDR version: Had to manually spin the lidar unit about 10-15 times without the neato cap on (spinning the top plastic where the screws are) and eventually the D3 started normally. Any idea if it is a faulty component, and what part (whole lidar, o-ring or motor) or should I not tempt fate and just pray it keeps working? It is currently doing a cleaning run now - will post info on if it stops.

Here's the scenario and what I've tried to get it working:

I have a D3 that has been working just fine up until a few nights ago, when I got the dreaded "reboot me" notification. Where after rebooting it, it moved about 10 inches from it's base and tried to start up 3 times, then ultimately stopped with a solid red indicator and green battery. Using my google fu, and coming across this site, I noticed many of the things were related to the lidar module.

I tried a few of the ideas posted that didn't require me to take it apart, (trying to cause a new error, let it sit, and do a battery full charge check exterior components, general stuff) I noticed that the brush and suction and wheels wer working (by pushing on the bumper making it very 'mad at me' and still no dice. I popped the blue lidar cap off and used gentile compressed air around the unit just in case still nothing. This evening however I was able to manually spin the lidar unit about 10 times each direction, and lo and it started normally. Any idea what would cause this behavior? If so any ideas on how to prevent or repair it should a manual spin not work?


Re: D3 "jumpstart" lidar question

December 31st, 2018, 12:12 am

I thought the D3 ditched the O ring? Can you see the laser on? My xv-11 had fuzz stuck in an internal optical sensor that reads RPM of the LIdAR, but I hear that is unusual. I'd verify RPM and go from there.

Re: D3 "jumpstart" lidar question

December 31st, 2018, 12:20 am

It's possible that some debris insulated the motor brushes from contacting the armature. Your spinning action cleared the debris.

All Neato Botvac Lidar units require O-rings.

Re: D3 "jumpstart" lidar question

December 31st, 2018, 6:42 am

I have had the same issue so time ago with my D3.
But as I am not scared to take it apart, I took of the lid.

It was visible that the touret was not spinning and causing this behaviour, so I tried to spin it by hand.
What I noticed is that the touret AND the o-ring were spinning, but the pulley of the motor did not!
The motor was somehow stuck inside.
I took of the o-ring and tried to rotate the pulley with my fingers and suddenly it snapt free.

Now I hooked it up to "Neato Control" and started the lidar from the test section.
It was running normally. When I try to slow it down the voltage is increased and it will try to remain the right rpm.
Without the o-ring it goes full throttle...

I put everything back together and did not see that error again.

Re: D3 "jumpstart" lidar question

January 6th, 2019, 9:49 am

Well, it lasted a week!

Now the motor is stuck again. I managed to get it free again by turning left/right till it gets going.
But electrically it is broken now. I can hear it rattle if I spin it by hand.
Perhaps a bad batch of motors?
Post a reply