Neato Botvac D3 Connected - Blue / Green light flashing

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Neato Botvac D3 Connected - Blue / Green light flashing

Postby RobertABooey » January 20th, 2019, 7:09 pm

Hi All,

I have a year old Neato Botvac D3 Connected that's currently unusable. When I turn the vacuum on, I see alternating blue / green flashing lights. Occasionally I'm able to get the vacuum to turn on successfully, but the app says the vacuum is at 0%, with time left to charge 0:00. I'm curious to know what my options are, or if I'm going to have to buy a new vacuum.

Thanks,
Bababooey
RobertABooey
 
Posts: 3
Joined: January 20th, 2019, 7:02 pm

Re: Neato Botvac D3 Connected - Blue / Green light flashing

Postby susantx3 » January 21st, 2019, 1:32 am

susantx3
Robot Groupie
 
Posts: 85
Joined: March 31st, 2007, 2:24 am

Re: Neato Botvac D3 Connected - Blue / Green light flashing

Postby RobertABooey » January 21st, 2019, 5:31 pm

I have not. Is there an easy way to do a diagnostic test on the existing battery?
RobertABooey
 
Posts: 3
Joined: January 20th, 2019, 7:02 pm

Re: Neato Botvac D3 Connected - Blue / Green light flashing

Postby vic7767 » January 21st, 2019, 5:59 pm

Use a digital volt meter and measure the stored voltage. It must be above 12 vdc.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14895
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato Botvac D3 Connected - Blue / Green light flashing

Postby JoostW » February 12th, 2019, 3:32 pm

I'm having the same problem. Bought a new battery en just installed it, but blue and green lights keep flashing.

The D3 doesn't react at all. My app als does not connect.
JoostW
 
Posts: 1
Joined: February 12th, 2019, 3:24 pm

Re: Neato Botvac D3 Connected - Blue / Green light flashing

Postby RobertABooey » March 11th, 2019, 7:58 pm

Just an update after I had some inspiration to try and fix the botvac.

I ended up rebooting the botvac with downgraded software. I did that by following these steps.

1. Remove the dustbin from the botvac
2. Remove the botvac from the base
3. Hold the start button for 10 seconds until the unit powers down
4. Press and hold the left front and left side bumper in, and hold the start button for 10+ seconds until the unit powers on
5. Setup the botvac on your phone app (you may need to soft boot the botvac again)

After the downgrade, I'm successfully able to get the botvac to turn on and I'm able to control it via the phone, however I'm currently experience a 3000 error code, so it's still broken.

Also, I ended up doing 2 software updates, one to 3.2.0-305, and one to 4.4.0-72. After updating to 4.4.0-72, it broke the botvac again. So if you end up going down this route, only update the software once and you might have a chance at having a working botvac again.
RobertABooey
 
Posts: 3
Joined: January 20th, 2019, 7:02 pm


Return to Neato Robotics

Who is online

Users browsing this forum: Akebra, ASTMedic, benjamink, BrettS, drunkpenguin, im1kissfan, jdong, jobs.jdfournier, johnnyh, lanchez, mfortuna, Rar9, RockinRay, someoneclever and 351 guests