Help to investigate error 3000

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Help to investigate error 3000

Postby egisklaip » February 7th, 2019, 1:47 pm

I am receiving message - Please press OK to continue (3000), some time (1070). I have changed already a lidar motor and changes lidar bearing. Still have the same problem :(. Neato support stated: there are two options 1. Lidar 2.Mainboard. It does not sound optimistic.
My questions are:
1. How exactly to detect is it LIDAR. If yes what is exactly, sensor, laser or lidar electronics?
2. Is it mainboard?
Sorry for my english, I am not native speaker. Really appreciate your help robot gurus :)
egisklaip
 
Posts: 12
Joined: January 19th, 2019, 1:27 pm

Re: Help to investigate error 3000

Postby egisklaip » February 8th, 2019, 5:34 pm

selling for parts,,:(
egisklaip
 
Posts: 12
Joined: January 19th, 2019, 1:27 pm

Re: Help to investigate error 3000

Postby fmulders » February 9th, 2019, 5:02 am

You can diagnose with "Neato controle". Little prog. what you can use to see the output of the lidar.
https://bitbucket.org/heXor/neatocontrol/downloads/neatocontrol.zip

You have not mentioned the type of Neato you have.
Can you see the Lidar spin?
Does it spin in the right direction? (You reversed the leads from the new motor?)
User avatar
fmulders
Robot Groupie
 
Posts: 53
Joined: February 3rd, 2018, 12:25 pm
Location: The Netherlands

Re: Help to investigate error 3000

Postby HiTec » February 9th, 2019, 8:19 am

Yeap, hook it to PC, use neatocontrol and let the LDS test to draw a map and see if it sees anything. Then post results here.
HiTec
Robot Groupie
 
Posts: 90
Joined: February 8th, 2015, 8:17 am

Re: Help to investigate error 3000

Postby egisklaip » February 9th, 2019, 9:46 am

HiTec wrote:Yeap, hook it to PC, use neatocontrol and let the LDS test to draw a map and see if it sees anything. Then post results here.

I have tested already with neatocontrol. The lidar is spinning but it does not see the objects, mostly of the time during testing program "Scanner" window ir red colour. Only few times flashes green spots and again - red program window (which means error). I beleave it is not scanning properly. I was trying to adjust focus of laser diod and lens.
The lidar cords are in right order and spinning right.
What other options? The motor power from main board is 13v. The power on lidar board 4 contacts was 3.4v.
What more I can measure or check?
Neato Botvac e70
egisklaip
 
Posts: 12
Joined: January 19th, 2019, 1:27 pm

Re: Help to investigate error 3000

Postby egisklaip » February 10th, 2019, 7:58 am

How to measure RPM of lidar?
egisklaip
 
Posts: 12
Joined: January 19th, 2019, 1:27 pm

Re: Help to investigate error 3000

Postby HiTec » February 10th, 2019, 12:46 pm

If i recall correctly, the speed is visible in the testing page once its turning. It should be around 5Hz.
HiTec
Robot Groupie
 
Posts: 90
Joined: February 8th, 2015, 8:17 am


Return to Neato Robotics

Who is online

Users browsing this forum: ASTMedic, im1kissfan, Ionic, jdong, vic7767 and 205 guests