XV12 received as gift, need to update firmware

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

XV12 received as gift, need to update firmware

Postby eilerstg » March 30th, 2019, 4:50 pm

Hi all,
I received an older XV12 as a gift. Seems to work OK, sometimes, then have several battery errors.
I checked the firmware and it's very old, apparently.
SW 3.0.17235
LDS V2.6.15295
Board Rev 64
Board SW 17242

I followed along with downloading the control app, which worked and I was able to control the wheels, motor, fan, etc...

However, I am trying to download the Updater/Installer and it won't install on my computer. Win 10.

Is there anyone who can help me update this firmware and which firmware is right for my particular model/version?
Thanks.
eilerstg
 
Posts: 2
Joined: March 30th, 2019, 4:44 pm

Re: XV12 received as gift, need to update firmware

Postby glnc222 » March 30th, 2019, 8:02 pm

Downloading and installing are two different things so not clear what is the problem. The driver/installer package is no longer available at the Neato Robotics website, but a copy is available on this site, see the Neato Control thread.
This package was written for an earlier version of Windows but might work in Windows 10, which goes back to the driver specs for Windows 7 I think, with Windows 8 being the problem version.

You then need the updating scripts and firmware files, with two systems available, the Vorwerk method and the Neato Robotics method (an updater program is installed along with the USB driver, a script driven terminal emulator). Firmware flashing is performed by the Neato itself, with data supplied over USB. See links in the Mods & Repairs list top of forum. It is critical to use the correct firmware file for your model or the system can be damaged. There is a risk of damaging the system beyond repair with any failure in the updating process, and it may not be worthwhile, matter of taste.

Not a whole lot was added beyond version 3.1 IMHO.
glnc222
Robot Master
 
Posts: 4943
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: XV12 received as gift, need to update firmware

Postby eilerstg » April 1st, 2019, 8:42 am

Thanks glnc222. I ordered new batteries for the unit and will just wait to see if that fixes the battery error problems. The problem on the updater/installer program was that I could download it, but during the installation process, it failed multiple times on my computer.

If the new batteries don't fix the battery errors on this unit, I'll try to update the SW since the unit is still on 3.0.
eilerstg
 
Posts: 2
Joined: March 30th, 2019, 4:44 pm

Re: XV12 received as gift, need to update firmware

Postby JEfromCanada » April 1st, 2019, 11:12 pm

At one point, I think there were issues running the update program on AMD-based computers. Something about the USB driver, I think. Anyway, I had experienced a similar problem (long ago) when trying to update with my desktop computer (AMD based) and ended up using a laptop (Intel-based) to get the job done.
Current robots:
Roomba Discovery 4210 (R.I.P. - Freecycled)
Roomba 560 (retired)
Neato XV-11 SW version 3.1.17844, LDS version 2.6.15295, with Pet Brush and Vic's filter (sold)
Neato Botvac 80 SW version 1.1.97, LDS version 2.6.15295, Board SW version 22753
JEfromCanada
Robot Addict
 
Posts: 673
Joined: November 13th, 2007, 5:16 pm
Location: Canada

Re: XV12 received as gift, need to update firmware

Postby glnc222 » April 4th, 2019, 4:22 pm

The AMD problem is not a failure to install the Neato driver. It is a defect in the AMD's Nvidia system board driver for the USB system, which affects only the unusual protocol used by Neato, sending single character packets to adapt an old teletype style interface, RS232 to USB. Because this defect did not affect any other products, it was never fixed by those PC makers, but newer AMD systems with all new system board software lacks the problem. The problem shows up only in communication with the Neato, where the connection does not go through, i.e. typing characters in a terminal emulator do not receive any echo from the Neato. The ports all appear operational as far as Windows is concerned, and the Neato driver is operational. System services called by this driver just don't work properly in this case. Neato Robotics advised of this and said to use Intel based PC's. I think those old systems have to be more than five years old at this point, maybe even older. Just need to know when trying to use some very old PC or laptop.
glnc222
Robot Master
 
Posts: 4943
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Neato Robotics

Who is online

Users browsing this forum: BrettS, cdogstu99, im1kissfan, jdong, vicdeng and 361 guests