Page 1 of 1

Neato D3 Started making this weird, loud clicking noise

PostPosted: April 2nd, 2019, 8:25 pm
by abs9986
My neato d3 started making this loud, clicking noise. We have had the robot for about 3 years and use about once per week. It sounds like the spinning wheel in wheel of fortune (i uploaded a video).

1. I confirmed it's not the brush. I removed the brush and still hear the noise
2. When I first start the neato, it sounds normal for about the first 5 seconds, then I hear the clicking noise

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 2nd, 2019, 8:37 pm
by abs9986
It won't let me upload the video, but here is a link to the video on my google drive:

https://photos.app.goo.gl/B576LWs25GgYAMKe9

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 3rd, 2019, 4:27 pm
by abs9986
Bump

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 3rd, 2019, 4:50 pm
by JEfromCanada
Not only is bumping rude, but after less than 24 hours, completely unnecessary.

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 3rd, 2019, 9:18 pm
by vic7767
abs9986 wrote:Bump
Download the Neato Control program and use the commands to activate each motor to help you identify which motor may be generating the noise.

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 3rd, 2019, 9:42 pm
by TechGuy
If you ignore the noise, will is continue to clean?
If no, it may be the LIDAR problem.
If your D3 start and stop 3 times and does not continue to clean, LIDAR problem.

As suggested by @vic7767, use the NeatoControl to start/stop one motor at a time to find out what is the source of the noise. Please note that there is a motor in the LIDAR module.

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 4th, 2019, 5:27 pm
by abs9986
Upon opening the neato d3, the sound is definitely coming from the motor toward the front, which I think is the brush motor.

Attached to the motor is a little gear which I think spins the brush motor. That gear and the the little nut where the roller attaches - it spins a few times and then it tightens and then loosens back up. I believe this is the source of the issue.

I included a picture of what I'm talking about. So look at the picture on the right. Where I pointed the arrow (the thing that looks like a nut where you insert the brush) - If I spin that with my hand, it will spin maybe 3 times, then it starts to tighten - almost to the point of not moving, but then it loosesns back up again and then retightens. The same things happens when spinning the black circle based on the picture on the left side. It's like there's some issue with the gear inside the motor

Any suggestions?

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 5th, 2019, 1:00 am
by Brett
Pull that unit out (it clips in) and clip it open - you will find a toothed belt inside, and (I'm guessing) a whole lot of crud too...

(-8

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 5th, 2019, 9:45 am
by abs9986
Are you talking about the motor I.e the picture on the left side or the module on the bottom is picture on the right side?

Re: Neato D3 Started making this weird, loud clicking noise

PostPosted: April 7th, 2019, 3:25 am
by fmulders
abs9986 wrote:Are you talking about the motor I.e the picture on the left side or the module on the bottom is picture on the right side?


The module on the right.
Never let a Neato of this type run without a brush. The gear which is used to spin the brush is not centered if the brush is absent. This will destroy the gear.
Open the black box and clean it out. You can add grease to smooth things up. I have a D85 running with a destroyed gear but when grease is applied it still runs without extra noise.