Page 1 of 1

Help: Cannot get wifi working on BotVac Connected

PostPosted: April 2nd, 2019, 9:08 pm
by petar
Hi there.

I have a Neato Botvac Connected with software version 2.2.0 (build 296). Last year, I lost wifi connectivity with it and since then, I've tried many times to get it connected again. No luck. I've read the troubleshooting guide, videos, etc. but to no avail. Reflashed the latest firmare too. I cannot get the BotVac to go into wifi pairing mode (ie. as a wifi access point), that is, I cannot get the wifi icon to appear on the screen.

In the top left corner of the BotVac's screen, it alternates between displaying a cross (X) symbol for a few seconds, and then that X gets replaced by a set of vertical bars for a few seconds (looks like the icon used to show the 4G signal strength on a mobile phone - see photo below). From what I have read (and what I recall when I originally set up the BotVac), there should be a wifi icon in that position (i.e. the BotVac goes into pairing mode) which would allow the Neato app on my mobile phone to connect to the BotVac.

Image

Unfortunately, I just cannot get that wifi icon to appear. I have tried resetting the BotVac, disabling and enabling the wifi, removing the existing network, etc. but nothing has helped.

When I enter the wifi settings on the BotVac, it shows me the option to 'Remove Network', but when I select that, and come back to the same screen, it appears again. It's like the BotVac is remembering a previous wifi network, and won't remove it.

Image

Other than the wifi not working, the BotVac works perfectly and vaccums our house once a week without fail.

Any ideas?

Thanks,
Pete

Re: Help: Cannot get wifi working on BotVac Connected

PostPosted: April 4th, 2019, 3:44 pm
by petar
I’ve posted a video showing what happens when I try to remove the existing network from my Botvac. It just keeps reappearing. Before doing this, I switched of our wifi router at home, to make sure the Botvac wasn’t somehow connecting to Neato servers automatically. As you can see in the video, instead of the wifi icon appearing, it only shows the the cross symbol (X).

https://www.youtube.com/watch?v=YjMNNqp0Xbs

BTW, when I tried doing the same steps with our wifi router switched on, I was able to get the vertical bars showing (as per the photo in my first post). The icon was flashing on and off every few seconds, which seemed like the Botvac was in pairing mode. As I said earlier, I was unable to connect to it using the neato app on both iPhone and Android devices. I wonder what that icon actually represents (4 vertical bars)?

Re: Help: Cannot get wifi working on BotVac Connected

PostPosted: April 4th, 2019, 10:00 pm
by someoneclever
The Wi-Fi icon indicates pairing mode (robot creates its own network). Flashing bars like a phone’s signal indicator mean the robot is connected to your network and is trying to reach Neato servers. Solid bars indicate a successful connection to your network and to Neato servers.

Re: Help: Cannot get wifi working on BotVac Connected

PostPosted: April 7th, 2019, 6:27 pm
by petar
someoneclever wrote:The Wi-Fi icon indicates pairing mode (robot creates its own network). Flashing bars like a phone’s signal indicator mean the robot is connected to your network and is trying to reach Neato servers. Solid bars indicate a successful connection to your network and to Neato servers.


Thanks for the info. I guess the the issue with my Botvac is that I am unable to remove the existing network. I have selected the 'Remove Network' option many times, and even after a reset, the flashing bars appear again and I can never get to the wifi icon.

Re: Help: Cannot get wifi working on BotVac Connected

PostPosted: July 3rd, 2019, 6:51 am
by Griffin
Are other devices connected to your wifi? Sometimes renaming your SSID can work too. But all connected devices and gadgets will get disconnected, you'll have to reconnect everything again. Hopefully this time, the neato can already recognize your network. If other gadgets can still connect and neato won't, it might be best to call neato support.

Re: Help: Cannot get wifi working on BotVac Connected

PostPosted: July 6th, 2019, 8:52 am
by hardrada
Hi, did you ever find a solution to this? Mine is having the same problem, like you I have tried all the various resets and removals and I get exactly the same, can't remove the network and can't get into pairing mode.