D85 Lidar issue in Neatocontrol

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

D85 Lidar issue in Neatocontrol

Postby ekjohns » April 29th, 2019, 1:12 pm

Hi all,

I have been getting the 3000 error code with my D85. I have been running the neatocontrol and I can get the LIDAR to turn off and on in the Scanner tab. However, I can not get it to display in mapping information. Nothing is displayed while it is spinning. Is there anything I can do to get this information. I believe the motor is dying as it speeds up and slows down, and is overall spinning slow. I have tried to get information in the LifeStatLog but I get the following error:

GetLifeStatLog
Unknown Cmd: 'GetLifeStatLog'

Any help would be much appreciated
ekjohns
 
Posts: 1
Joined: April 29th, 2019, 1:07 pm

Re: D85 Lidar issue in Neatocontrol

Postby glnc222 » April 29th, 2019, 4:07 pm

The lidar can be tested over USB in addition to Neato Control using a terminal emulator program and the text command language in the Neato, manual linked top of this forum. A separate command spins the lidar before using another command to get a scan, returning 360 degree measurements. Neato Control simply renders this data into a graphical display and interface to these text commands. You may have to set Test Mode ON to run the lidar, not sure. Test Mode is for separately operating motors etc., and must be turned off manually before closing the USB connection; the Neato will not clean in Test Mode.

It is possible the scan operation will not work if the spin rotation is not stable and the correct rpm, allowing timing to measure the angle of the beam, though I am not sure of the behavior in different failure modes. Several mechanical factors can wear out such as the belt, bearing and slip ring, but the most common repair is replacing the spin motor, covered in other threads -- the brushes wear out... Age of the unit should be considered. There are some internal details of lidar which are sometimes repaired such as focus of the lenses etc., but not frequent. Whether the unit was working previously should be considered.
glnc222
Robot Master
 
Posts: 4910
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: D85 Lidar issue in Neatocontrol

Postby glnc222 » April 30th, 2019, 12:38 pm

Forgot to mention LiFeStatLog does not appear supported in the Botvac firmware compared to the older XV models. The command in the manual is not listed in the HELP command output of command list.
glnc222
Robot Master
 
Posts: 4910
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Neato Robotics

Who is online

Users browsing this forum: BrettS, im1kissfan, jdong, johnnyh, vic7767 and 376 guests